summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD34
-rw-r--r--gtkparasite-gtk2.install16
3 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e1cb334d00c3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = gtkparasite-gtk2
+ pkgdesc = GTK+ debugging and development tool for GTK+2 applications
+ pkgver = 0.2.0.71.0a0c90b
+ pkgrel = 1
+ url = http://chipx86.github.io/gtkparasite/
+ install = gtkparasite-gtk2.install
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = gnome-common
+ depends = pygtk
+ depends = gtk2
+ depends = gtksourceview2
+ options = !libtool
+ source = gtkparasite-gtk2-0.2.0.71.0a0c90b.tar.gz::https://github.com/chipx86/gtkparasite/archive/0a0c90b7098d8c5b8bc06ecc88459520ad533601.tar.gz
+ sha256sums = 16a3c575166cfdb9052cd96b2e8df6a4036941249fd1dc91b4781eeca7fade37
+
+pkgname = gtkparasite-gtk2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9862d9170a28
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Muflone http://www.muflone.com/contacts/english/
+
+pkgname=gtkparasite-gtk2
+pkgver=0.2.0.71.0a0c90b
+pkgrel=1
+_gitcommit=0a0c90b7098d8c5b8bc06ecc88459520ad533601
+pkgdesc="GTK+ debugging and development tool for GTK+2 applications"
+url=http://chipx86.github.io/gtkparasite/
+arch=(i686 x86_64)
+license=(MIT)
+depends=('pygtk' 'gtk2' 'gtksourceview2')
+makedepends=('git' 'gnome-common')
+options=(!libtool)
+source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/chipx86/${pkgname%%-*}/archive/${_gitcommit}.tar.gz")
+sha256sums=('16a3c575166cfdb9052cd96b2e8df6a4036941249fd1dc91b4781eeca7fade37')
+install="${pkgname}.install"
+
+prepare() {
+ # Replace old AutoMake macro with new one
+ sed -i 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/g' "${pkgname%%-*}-${_gitcommit}/configure.ac"
+}
+
+build() {
+ cd "${pkgname%%-*}-${_gitcommit}"
+ PYTHON=python2 ./autogen.sh --prefix=/usr --with-gtk=2.0
+ make
+}
+
+package() {
+ cd "${pkgname%%-*}-${_gitcommit}"
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
+}
+
diff --git a/gtkparasite-gtk2.install b/gtkparasite-gtk2.install
new file mode 100644
index 000000000000..228bd7d320fd
--- /dev/null
+++ b/gtkparasite-gtk2.install
@@ -0,0 +1,16 @@
+post_install()
+{
+ cat << EOF
+
+To use gtkparasite for a GTK+ 2.0 application execute:
+GTK_MODULES=gtkparasite gtk2-application
+like:
+GTK_MODULES=gtkparasite leafpad
+
+EOF
+}
+
+post_upgrade()
+{
+ post_install
+}