summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD24
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bd6fd497446d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,11 @@
+pkgbase = gtksourceview2
+ pkgdesc = A text widget that extends the standard gtk+ 2.x
+ pkgver = 2.10.5
+ pkgrel = 1
+ url = https://download.gnome.org/sources/gtksourceview
+ arch = x86_64
+ license = GNU
+ source = https://download.gnome.org/sources/gtksourceview/2.10/gtksourceview-2.10.5.tar.gz
+ md5sums = 220db5518e3f7fa06c980f057b22ba62
+
+pkgname = gtksourceview2
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..33ea4ea83e93
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Jason Kercher <jkercher43 at gmail>
+pkgname=gtksourceview2
+pkgver=2.10.5
+pkgrel=1
+pkgdesc="A text widget that extends the standard gtk+ 2.x"
+arch=(x86_64)
+url="https://download.gnome.org/sources/gtksourceview"
+license=(GNU)
+depends=()
+checkdepends=()
+provides=()
+source=("$url/2.10/gtksourceview-$pkgver.tar.gz")
+md5sums=(220db5518e3f7fa06c980f057b22ba62)
+
+build() {
+ cd "gtksourceview-$pkgver/"
+ ./configure
+ make
+}
+
+package() {
+ cd "gtksourceview-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}