summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD15
2 files changed, 14 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e4cc026b929c..f268de6a1c7b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,20 @@
pkgbase = gtksourceview5
pkgdesc = A text widget adding syntax highlighting and more to GNOME
- pkgver = 5.1.0
+ pkgver = 5.4.0
pkgrel = 1
url = https://gitlab.gnome.org/GNOME/gtksourceview
arch = x86_64
arch = aarch64
license = LGPL
checkdepends = xorg-server-xvfb
+ makedepends = gi-docgen
makedepends = gobject-introspection
makedepends = gtk-doc
makedepends = meson
makedepends = vala
depends = gtk4
- source = https://gitlab.gnome.org/GNOME/gtksourceview/-/archive/5.1.0/gtksourceview-5.1.0.tar.gz
- sha256sums = SKIP
+ options = debug
+ source = https://gitlab.gnome.org/GNOME/gtksourceview/-/archive/5.4.0/gtksourceview-5.4.0.tar.gz
+ b2sums = 8367251603d117e9bdc6621b6faf818e7447b8522ed4cf34dca6f08592029bebe7b3cd92d75bffe2b6279f6ef3786d398081f083d8a0733ad03a18f76b416bc1
pkgname = gtksourceview5
diff --git a/PKGBUILD b/PKGBUILD
index 00088fa663f2..1fcb1b420f82 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,28 @@
# Maintainer: Philip Goto <philip.goto@gmail.com>
pkgname=gtksourceview5
-pkgver=5.1.0
+pkgver=5.4.0
pkgrel=1
pkgdesc='A text widget adding syntax highlighting and more to GNOME'
-url='https://gitlab.gnome.org/GNOME/gtksourceview'
-license=('LGPL')
arch=(x86_64 aarch64)
+url='https://gitlab.gnome.org/GNOME/gtksourceview'
+license=(LGPL)
depends=(gtk4)
makedepends=(
+ gi-docgen
gobject-introspection
gtk-doc
meson
vala
)
checkdepends=(xorg-server-xvfb)
-source=("${url}/-/archive/${pkgver}/gtksourceview-${pkgver}.tar.gz")
-sha256sums=('SKIP')
+options=(debug)
+_commit=${pkgver}
+source=("${url}/-/archive/${_commit}/gtksourceview-${_commit}.tar.gz")
+b2sums=('8367251603d117e9bdc6621b6faf818e7447b8522ed4cf34dca6f08592029bebe7b3cd92d75bffe2b6279f6ef3786d398081f083d8a0733ad03a18f76b416bc1')
build() {
- arch-meson gtksourceview-${pkgver} build -D gtk_doc=true
+ arch-meson gtksourceview-${_commit} build -D gtk_doc=true
meson compile -C build
}