summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD25
-rw-r--r--guacamole-server.install1
-rw-r--r--guacd.conf23
-rw-r--r--libavcodec.patch12
5 files changed, 44 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 675adf08f1a1..53b90a369279 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = guacamole-server
pkgdesc = Guacamole proxy daemon
- pkgver = 1.3.0
- pkgrel = 3
+ pkgver = 1.4.0
+ pkgrel = 1
url = http://guacamole.sourceforge.net/
install = guacamole-server.install
arch = i686
@@ -32,10 +32,10 @@ pkgbase = guacamole-server
replaces = libguac-client-ssh
replaces = libguac-client-vnc
replaces = libguac-client-rdp
- source = http://apache.org/dyn/closer.cgi?action=download&filename=guacamole/1.3.0/source/guacamole-server-1.3.0.tar.gz
- source = https://github.com/apache/guacamole-server/commit/b2ae2fdf003a6854ac42877ce0fce8e88ceb038a.patch
- md5sums = 5203866c9de4e8c064b19a56a95599c6
- md5sums = 166e637d961e691f29b298c211ee2fd5
+ backup = etc/guacamole/guacd.conf
+ source = http://apache.org/dyn/closer.cgi?action=download&filename=guacamole/1.4.0/source/guacamole-server-1.4.0.tar.gz
+ source = guacd.conf
+ md5sums = b17c6152e96af0488ca4c0608e5ec3ae
+ md5sums = ab0ac97ad76d16be73768f89abb6ee7e
pkgname = guacamole-server
-
diff --git a/PKGBUILD b/PKGBUILD
index e124dd228e57..50e026338716 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Contributor: Black_Codec <orso.f.regna@gmail.com>
pkgname=guacamole-server
-pkgver=1.3.0
-pkgrel=3
+pkgver=1.4.0
+pkgrel=1
pkgdesc="Guacamole proxy daemon"
arch=('i686' 'x86_64' 'armv7h')
url="http://guacamole.sourceforge.net/"
@@ -22,26 +22,27 @@ optdepends=('libssh: for ssh protocol support'
install=$pkgname.install
source=("http://apache.org/dyn/closer.cgi?action=download&filename=guacamole/${pkgver}/source/${pkgname}-${pkgver}.tar.gz"
- "https://github.com/apache/guacamole-server/commit/b2ae2fdf003a6854ac42877ce0fce8e88ceb038a.patch")
-
-md5sums=('5203866c9de4e8c064b19a56a95599c6'
- '166e637d961e691f29b298c211ee2fd5')
+ "guacd.conf")
-prepare() {
- cd "$srcdir"/$pkgname-$pkgver
- patch -Np1 -i ../b2ae2fdf003a6854ac42877ce0fce8e88ceb038a.patch
-}
+backup=('etc/guacamole/guacd.conf')
+
+md5sums=('b17c6152e96af0488ca4c0608e5ec3ae'
+ 'ab0ac97ad76d16be73768f89abb6ee7e')
+
+#prepare() {
+#}
build() {
cd "$srcdir"/$pkgname-$pkgver
-
# guacenc doesn't work since ffmpeg 4.4 (av_init_packet() is deprecated) that's why we have to build it with --disable-guacenc
# Reference: https://issues.apache.org/jira/browse/GUACAMOLE-1330
- ./configure --prefix=/usr --sbindir=/usr/bin --with-systemd-dir=/usr/lib/systemd/system --disable-guacenc CPPFLAGS="-Wno-error=pedantic"
+ ./configure --prefix=/usr --bindir=/usr/bin --sbindir=/usr/bin --with-systemd-dir=/usr/lib/systemd/system --disable-guacenc CPPFLAGS="-Wno-error=pedantic"
make
}
package() {
cd "$srcdir"/$pkgname-$pkgver
make DESTDIR="$pkgdir" install
+ mkdir -p "$pkgdir"/etc/guacamole
+ cp -f ../guacd.conf "$pkgdir"/etc/guacamole/
}
diff --git a/guacamole-server.install b/guacamole-server.install
index fde9d5c58622..d7299fbfd1be 100644
--- a/guacamole-server.install
+++ b/guacamole-server.install
@@ -14,6 +14,7 @@ yellow="${bold}$(tput setaf 3)"
post_install() {
note "You need to have, at least, 1 monospace font installed in your system. Check optdepends to see some examples."
+ note "Now this package ships a default configuration in file /etc/guacamole/guacd.conf. Remember to change it according to your setup. By default guacd will listen to 127.0.0.1 only."
}
post_upgrade() {
diff --git a/guacd.conf b/guacd.conf
new file mode 100644
index 000000000000..870abb771703
--- /dev/null
+++ b/guacd.conf
@@ -0,0 +1,23 @@
+#
+# guacd configuration file
+#
+
+[daemon]
+
+#pid_file = /var/run/guacd.pid
+log_level = info
+
+[server]
+
+bind_host = 127.0.0.1
+bind_port = 4822
+
+#
+# The following parameters are valid only if
+# guacd was built with SSL support.
+#
+
+#[ssl]
+
+#server_certificate = /etc/ssl/certs/guacd.crt
+#server_key = /etc/ssl/private/guacd.key
diff --git a/libavcodec.patch b/libavcodec.patch
deleted file mode 100644
index 06de5db01873..000000000000
--- a/libavcodec.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- a/src/guacenc/guacenc.c 2018-05-25 00:11:40.315468138 +0200
-+++ b/src/guacenc/guacenc.c 2018-05-25 00:11:32.011384353 +0200
-@@ -76,7 +76,9 @@
- "version " VERSION);
-
- /* Prepare libavcodec */
-+#if LIBAVCODEC_VERSION_INT < AV_VERSION_INT(58, 9, 100)
- avcodec_register_all();
-+#endif
-
- /* Track number of overall failures */
- int total_files = argc - optind;