summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD15
-rw-r--r--archlinux.patch6
3 files changed, 20 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5236f6057004..0eb84358ffdd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Tue Feb 23 02:20:27 UTC 2016
pkgbase = guile-dbd-postgresql
pkgdesc = guile-dbi database driver postgresql
- pkgver = 2.1.4
- pkgrel = 2
+ pkgver = 2.1.6
+ pkgrel = 1
url = http://home.gna.org/guile-dbi/
arch = i686
arch = x86_64
@@ -9,9 +11,9 @@ pkgbase = guile-dbd-postgresql
depends = guile-dbi>=2.1.2
depends = postgresql-libs
source = archlinux.patch
- source = http://download.gna.org/guile-dbi/guile-dbd-postgresql-2.1.4.tar.gz
- md5sums = df216c4714ee3d7994c61e06b8767b43
- md5sums = 18a7b642570bf251ebe9255745fb5afd
+ source = http://download.gna.org/guile-dbi/guile-dbd-postgresql-2.1.6.tar.gz
+ md5sums = 12e77b8ad0c512571a1be829c5e045e6
+ md5sums = 93e6271b4b9ad9abac3fa16cd0b114ad
pkgname = guile-dbd-postgresql
diff --git a/PKGBUILD b/PKGBUILD
index 4a20aa086b8b..94335b0fa3dc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Andrea Girotto <andrea (dot) girotto (at) gmail (dot) com>
pkgname=guile-dbd-postgresql
-pkgver=2.1.4
-pkgrel=2
+pkgver=2.1.6
+pkgrel=1
pkgdesc='guile-dbi database driver postgresql'
arch=(i686 x86_64)
license=(GPL2)
@@ -9,16 +9,21 @@ depends=('guile-dbi>=2.1.2' postgresql-libs)
url=http://home.gna.org/guile-dbi/
source=(archlinux.patch
http://download.gna.org/guile-dbi/${pkgname}-${pkgver}.tar.gz)
-md5sums=('df216c4714ee3d7994c61e06b8767b43'
- '18a7b642570bf251ebe9255745fb5afd')
+md5sums=('12e77b8ad0c512571a1be829c5e045e6'
+ '93e6271b4b9ad9abac3fa16cd0b114ad')
build(){
cd ${srcdir}
patch -p0 < archlinux.patch
cd ${srcdir}/${pkgname}-${pkgver}
+ libtoolize
+ aclocal
+ autoscan
+ autoheader
+ automake
+ autoconf
./configure --prefix=/usr || return 1
make
-
}
package() {
diff --git a/archlinux.patch b/archlinux.patch
index 37ad9a1a35b6..db67f517b114 100644
--- a/archlinux.patch
+++ b/archlinux.patch
@@ -1,6 +1,6 @@
-diff -Naur guile-dbd-postgresql-2.1.4/src/guile-dbd-postgresql.c guile-dbd-postgresql-2.1.4-new/src/guile-dbd-postgresql.c
---- guile-dbd-postgresql-2.1.4/src/guile-dbd-postgresql.c 2008-12-13 23:44:28.000000000 +0100
-+++ guile-dbd-postgresql-2.1.4-new/src/guile-dbd-postgresql.c 2013-10-05 20:18:38.770299378 +0200
+diff -Naur guile-dbd-postgresql-2.1.6/src/guile-dbd-postgresql.c guile-dbd-postgresql-2.1.6-new/src/guile-dbd-postgresql.c
+--- guile-dbd-postgresql-2.1.6/src/guile-dbd-postgresql.c 2008-12-13 23:44:28.000000000 +0100
++++ guile-dbd-postgresql-2.1.6-new/src/guile-dbd-postgresql.c 2013-10-05 20:18:38.770299378 +0200
@@ -24,7 +24,7 @@
#include <guile-dbi/guile-dbi.h>