summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e257f2b067e2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = guile-shapefile
+ pkgdesc = Parse shapefiles (map data) in guile
+ pkgver = 0.1.2
+ pkgrel = 1
+ url = https://github.com/HugoNikanor/guile-shapefile
+ arch = any
+ license = MIT
+ depends = guile
+ options = !strip
+ source = https://github.com/HugoNikanor/guile-shapefile/archive/v0.1.2.tar.gz
+ md5sums = fb0cf028517ae3016ba91c1cd089d788
+
+pkgname = guile-shapefile
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..11a6d4068670
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Hugo Hörnquist <hugo@lysator.liu.se>
+
+pkgname=guile-shapefile
+pkgdesc='Parse shapefiles (map data) in guile'
+pkgver=0.1.2
+pkgrel=1
+arch=('any')
+license=('MIT')
+depends=('guile')
+url="https://github.com/HugoNikanor/$pkgname"
+source=("$url/archive/v$pkgver.tar.gz")
+options=('!strip')
+md5sums=('fb0cf028517ae3016ba91c1cd089d788')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make for-package
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make PREFIX=/usr DESTDIR=$pkgdir install
+}