summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO30
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD66
-rw-r--r--wxgtk3.patch27
4 files changed, 91 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e8e9d10558ac..f54db61131cc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sat Jul 21 13:52:42 UTC 2018
+# Sat Aug 4 06:21:28 UTC 2018
pkgbase = gura
pkgdesc = An iterator-oriented programming language
pkgver = 0.7.0
- pkgrel = 1
+ pkgrel = 2
url = http://www.gura-lang.org/
arch = i686
arch = x86_64
@@ -30,16 +30,40 @@ pkgbase = gura
makedepends = sdl2
makedepends = sqlite
makedepends = libtiff
- makedepends = wxgtk2
+ makedepends = wxgtk3
makedepends = expat
makedepends = libyaml
depends = readline
+ optdepends = bzip2
+ optdepends = cairo
+ optdepends = curl
+ optdepends = freetype2
+ optdepends = fftw
+ optdepends = glu
+ optdepends = freeglut
+ optdepends = gmp
+ optdepends = zlib
+ optdepends = libjpeg-turbo
+ optdepends = alsa-lib
+ optdepends = libgl
+ optdepends = mesa
+ optdepends = libpng
+ optdepends = oniguruma
+ optdepends = sdl
+ optdepends = sdl2
+ optdepends = sqlite
+ optdepends = libtiff
+ optdepends = wxgtk3
+ optdepends = expat
+ optdepends = libyaml
source = https://github.com/gura-lang/gura/releases/download/v0.7.0/gura-0.7.0-src.tar.gz
source = Value.h.patch
source = build-modules.gura.patch
+ source = wxgtk3.patch
md5sums = 5aeb3b21a5f78bd13c2d0940f1ed31d2
md5sums = ef277211f12747b5504e73f011c8cb9c
md5sums = 53597e9ab12a52468e010d2a1caa1262
+ md5sums = 8f6697c526c0308a502edd6fc634177c
pkgname = gura
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b63977a0ed66
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+src/
+pkg/
+*.tar.*
diff --git a/PKGBUILD b/PKGBUILD
index c739836b08e8..c66e9d57c50b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,52 +1,54 @@
# Maintainer: Michiru Saito <urihcim at gmail dot com>
pkgname=gura
pkgver=0.7.0
-pkgrel=1
+pkgrel=2
pkgdesc="An iterator-oriented programming language"
arch=('i686' 'x86_64')
url='http://www.gura-lang.org/'
license=('unknown')
+_moddepends=('bzip2'
+ 'cairo'
+ 'curl'
+ 'freetype2'
+ 'fftw'
+ 'glu'
+ 'freeglut'
+ 'gmp'
+ 'zlib'
+ 'libjpeg-turbo'
+ 'alsa-lib'
+ #'liblinear'
+ #'libsvm'
+ 'libgl'
+ 'mesa'
+ 'libpng'
+ 'oniguruma'
+ 'sdl'
+ 'sdl2'
+ 'sqlite'
+ #'tcl'
+ #'tk'
+ 'libtiff'
+ 'wxgtk3'
+ 'expat'
+ 'libyaml')
depends=('readline')
-makedepends=('cmake'
- 'make'
- 'gcc'
- 'bzip2'
- 'cairo'
- 'curl'
- 'freetype2'
- 'fftw'
- 'glu'
- 'freeglut'
- 'gmp'
- 'zlib'
- 'libjpeg-turbo'
- 'alsa-lib'
- #'liblinear'
- #'libsvm'
- 'libgl'
- 'mesa'
- 'libpng'
- 'oniguruma'
- 'sdl'
- 'sdl2'
- 'sqlite'
- #'tcl'
- #'tk'
- 'libtiff'
- 'wxgtk2'
- 'expat'
- 'libyaml')
+makedepends=('cmake' 'make' 'gcc' ${_moddepends[@]})
+optdepends=(${_moddepends[@]})
source=("https://github.com/gura-lang/gura/releases/download/v${pkgver}/gura-${pkgver}-src.tar.gz"
"Value.h.patch"
- "build-modules.gura.patch")
+ "build-modules.gura.patch"
+ "wxgtk3.patch")
md5sums=('5aeb3b21a5f78bd13c2d0940f1ed31d2'
'ef277211f12747b5504e73f011c8cb9c'
- '53597e9ab12a52468e010d2a1caa1262')
+ '53597e9ab12a52468e010d2a1caa1262'
+ '8f6697c526c0308a502edd6fc634177c')
prepare() {
cd "${srcdir}/${pkgname}-${pkgver}"
patch -p1 -i "${srcdir}/Value.h.patch"
patch -p1 -i "${srcdir}/build-modules.gura.patch"
+ patch -p1 -i "${srcdir}/wxgtk3.patch"
}
build() {
diff --git a/wxgtk3.patch b/wxgtk3.patch
new file mode 100644
index 000000000000..659e31ca1764
--- /dev/null
+++ b/wxgtk3.patch
@@ -0,0 +1,27 @@
+diff --git a/src/module-wx/build.gura b/src/module-wx/build.gura
+index 47c2ea688..e3a610688 100755
+--- a/src/module-wx/build.gura
++++ b/src/module-wx/build.gura
+@@ -684,11 +684,11 @@ if (sys.platform == `mswin) {
+ builder.rpmFiles = ['wxGTK3-3.0.3-2.fc27.x86_64']
+ builder.debFilesDevel = ['libwxgtk3.0-dev']
+ builder.rpmFilesDevel = ['wxGTK3-3.0.3-2.fc27.x86_64']
+- if (IsExist('wx-config')) {
++ if (IsExist('wx-config-gtk3')) {
+ cflags = scope {
+ buff = binary()
+ os.redirect(nil, buff) {
+- os.exec('wx-config', '--version=3.0', '--cppflags')
++ os.exec('wx-config-gtk3', '--version=3.0', '--cppflags')
+ }
+ os.fromnative(buff).strip().split(' '):list
+ }
+@@ -696,7 +696,7 @@ if (sys.platform == `mswin) {
+ ldflags = scope {
+ buff = binary()
+ os.redirect(nil, buff) {
+- os.exec('wx-config', '--version=3.0', '--libs',
++ os.exec('wx-config-gtk3', '--version=3.0', '--libs',
+ 'xrc,stc,richtext,ribbon,propgrid,aui,gl,html,qa,adv,core,xml,net,base')
+ }
+ str = os.fromnative(buff).replace('\n', ' ')