summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO45
-rw-r--r--PKGBUILD64
-rw-r--r--Value.h.patch30
-rw-r--r--build-modules.gura.patch34
4 files changed, 173 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e8e9d10558ac
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,45 @@
+# Generated by mksrcinfo v8
+# Sat Jul 21 13:52:42 UTC 2018
+pkgbase = gura
+ pkgdesc = An iterator-oriented programming language
+ pkgver = 0.7.0
+ pkgrel = 1
+ url = http://www.gura-lang.org/
+ arch = i686
+ arch = x86_64
+ license = unknown
+ makedepends = cmake
+ makedepends = make
+ makedepends = gcc
+ makedepends = bzip2
+ makedepends = cairo
+ makedepends = curl
+ makedepends = freetype2
+ makedepends = fftw
+ makedepends = glu
+ makedepends = freeglut
+ makedepends = gmp
+ makedepends = zlib
+ makedepends = libjpeg-turbo
+ makedepends = alsa-lib
+ makedepends = libgl
+ makedepends = mesa
+ makedepends = libpng
+ makedepends = oniguruma
+ makedepends = sdl
+ makedepends = sdl2
+ makedepends = sqlite
+ makedepends = libtiff
+ makedepends = wxgtk2
+ makedepends = expat
+ makedepends = libyaml
+ depends = readline
+ source = https://github.com/gura-lang/gura/releases/download/v0.7.0/gura-0.7.0-src.tar.gz
+ source = Value.h.patch
+ source = build-modules.gura.patch
+ md5sums = 5aeb3b21a5f78bd13c2d0940f1ed31d2
+ md5sums = ef277211f12747b5504e73f011c8cb9c
+ md5sums = 53597e9ab12a52468e010d2a1caa1262
+
+pkgname = gura
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c739836b08e8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,64 @@
+# Maintainer: Michiru Saito <urihcim at gmail dot com>
+pkgname=gura
+pkgver=0.7.0
+pkgrel=1
+pkgdesc="An iterator-oriented programming language"
+arch=('i686' 'x86_64')
+url='http://www.gura-lang.org/'
+license=('unknown')
+depends=('readline')
+makedepends=('cmake'
+ 'make'
+ 'gcc'
+ 'bzip2'
+ 'cairo'
+ 'curl'
+ 'freetype2'
+ 'fftw'
+ 'glu'
+ 'freeglut'
+ 'gmp'
+ 'zlib'
+ 'libjpeg-turbo'
+ 'alsa-lib'
+ #'liblinear'
+ #'libsvm'
+ 'libgl'
+ 'mesa'
+ 'libpng'
+ 'oniguruma'
+ 'sdl'
+ 'sdl2'
+ 'sqlite'
+ #'tcl'
+ #'tk'
+ 'libtiff'
+ 'wxgtk2'
+ 'expat'
+ 'libyaml')
+source=("https://github.com/gura-lang/gura/releases/download/v${pkgver}/gura-${pkgver}-src.tar.gz"
+ "Value.h.patch"
+ "build-modules.gura.patch")
+md5sums=('5aeb3b21a5f78bd13c2d0940f1ed31d2'
+ 'ef277211f12747b5504e73f011c8cb9c'
+ '53597e9ab12a52468e010d2a1caa1262')
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ patch -p1 -i "${srcdir}/Value.h.patch"
+ patch -p1 -i "${srcdir}/build-modules.gura.patch"
+}
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ mkdir -p build
+ cd build
+ ../configure
+ make
+ ./build-modules
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}/build"
+ make DESTDIR="${pkgdir}" install
+}
diff --git a/Value.h.patch b/Value.h.patch
new file mode 100644
index 000000000000..61fe69cd0883
--- /dev/null
+++ b/Value.h.patch
@@ -0,0 +1,30 @@
+diff --git a/include/gura/Value.h b/include/gura/Value.h
+index f0bc5f7ee..cf22eb4de 100644
+--- a/include/gura/Value.h
++++ b/include/gura/Value.h
+@@ -620,7 +620,7 @@ typedef std::deque<Value, Allocator<Value> > ValueDeque;
+ //-----------------------------------------------------------------------------
+ // ValueDict
+ //-----------------------------------------------------------------------------
+-class GURA_DLLDECLARE ValueDict : public std::map<Value, Value, Value::LessThan, Allocator<Value> > {
++class GURA_DLLDECLARE ValueDict : public std::map<Value, Value, Value::LessThan, Allocator<std::pair<const Value, Value> > > {
+ public:
+ enum StoreMode {
+ STORE_Strict,
+@@ -641,13 +641,13 @@ public:
+ MemoryPool::Deallocate(pv);
+ }
+ public:
+- inline ValueDict() : std::map<Value, Value, Value::LessThan, Allocator<Value> >(),
++ inline ValueDict() : std::map<Value, Value, Value::LessThan, Allocator<std::pair<const Value, Value> > >(),
+ _cntRef(1), _ignoreCaseFlag(false) {}
+ inline ValueDict(bool ignoreCaseFlag) :
+- std::map<Value, Value, Value::LessThan, Allocator<Value> >(ignoreCaseFlag? Value::LessThanIgnoreCase : Value::LessThanCase),
++ std::map<Value, Value, Value::LessThan, Allocator<std::pair<const Value, Value> > >(ignoreCaseFlag? Value::LessThanIgnoreCase : Value::LessThanCase),
+ _cntRef(1), _ignoreCaseFlag(ignoreCaseFlag) {}
+ inline ValueDict(const ValueDict &valDict) :
+- std::map<Value, Value, Value::LessThan, Allocator<Value> >(valDict),
++ std::map<Value, Value, Value::LessThan, Allocator<std::pair<const Value, Value> > >(valDict),
+ _cntRef(1), _ignoreCaseFlag(valDict._ignoreCaseFlag) {}
+ private:
+ inline ~ValueDict() {}
diff --git a/build-modules.gura.patch b/build-modules.gura.patch
new file mode 100644
index 000000000000..d4284db173d8
--- /dev/null
+++ b/build-modules.gura.patch
@@ -0,0 +1,34 @@
+diff --git a/src/build-modules.gura b/src/build-modules.gura
+index 510c0bfc5..c1f4fea74 100755
+--- a/src/build-modules.gura
++++ b/src/build-modules.gura
+@@ -37,8 +37,8 @@ moduleInfos = @(ModuleInfo) {
+ ['markdown', `build, [`mswin, `darwin, `ubuntu, `fedora, `centos, `redhat ]]
+ ['math', `skip, [`mswin, `darwin, `ubuntu, `fedora, `centos, `redhat ]] // integrated
+ ['midi', `build, [`mswin, `darwin, `ubuntu, `fedora, `centos, `redhat ]]
+- ['ml_linear', `build, [`mswin, `darwin, `ubuntu, `fedora, `centos, `redhat ]]
+- ['ml_svm', `build, [`mswin, `darwin, `ubuntu, `fedora, `centos, `redhat ]]
++ ['ml_linear', `skip, [`mswin, `darwin, `ubuntu, `fedora, `centos, `redhat ]]
++ ['ml_svm', `skip, [`mswin, `darwin, `ubuntu, `fedora, `centos, `redhat ]]
+ ['model_obj', `build, [`mswin, `darwin, `ubuntu, `fedora, `centos, `redhat ]]
+ ['model_stl', `build, [`mswin, `darwin, `ubuntu, `fedora, `centos, `redhat ]]
+ ['msico', `build, [`mswin, `darwin, `ubuntu, `fedora, `centos, `redhat ]]
+@@ -56,7 +56,7 @@ moduleInfos = @(ModuleInfo) {
+ ['sqlite3', `build, [`mswin, `darwin, `ubuntu, `fedora, `centos, `redhat ]]
+ ['sys', `skip, [`mswin, `darwin, `ubuntu, `fedora, `centos, `redhat ]] // integrated
+ ['tar', `build, [`mswin, `darwin, `ubuntu, `fedora, `centos, `redhat ]]
+- ['tcl', `build, [`mswin, `ubuntu, `fedora, `centos, `redhat ]]
++ ['tcl', `skip, [`mswin, `ubuntu, `fedora, `centos, `redhat ]]
+ ['tester', `skip, [`mswin, `darwin, `ubuntu, `fedora, `centos, `redhat ]] // just for test
+ ['tiff', `build, [`mswin, `darwin, `ubuntu, `fedora, `centos, `redhat ]]
+ ['uuid', `build, [`mswin, `darwin, ]]
+@@ -81,6 +81,9 @@ options:
+
+ if (sys.platform == `linux) {
+ platform = nil
++ if (path.exists('/etc/arch-release')) {
++ platform = `ubuntu
++ }
+ !platform && path.exists(fileName = '/etc/lsb-release') && \
+ readlines(fileName):chop {|line|
+ fields = line.split('='):list