summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD25
2 files changed, 17 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index beed5dbdee74..458823fa1a87 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
pkgbase = gvolwheel
pkgdesc = a lightweight audio mixer which lets you control the audio volume through a tray icon
- pkgver = 1.0
+ pkgver = 1.0.2
pkgrel = 1
- url = http://sourceforge.net/projects/gvolwheel/
+ url = https://github.com/Junker/gvolwheel
arch = i686
arch = x86_64
license = GPL-2
makedepends = intltool
depends = gtk3
- source = http://downloads.sourceforge.net/gvolwheel/gvolwheel-1.0.tar.gz
- md5sums = 4f04f00cdb875894c96b8a3ff8a9edb9
+ depends = libgee
+ source = https://github.com/Junker/gvolwheel/archive/1.0.2.zip
+ md5sums = 2bfde9ec2d9f288531626c1688c6b025
pkgname = gvolwheel
diff --git a/PKGBUILD b/PKGBUILD
index b5e4e5b6087c..9d654b020bbe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,26 @@
# Maintainer: Jozef Riha <jose1711 at gmail dot com>
+# Contributor: Junker
pkgname=gvolwheel
-pkgver=1.0
+pkgver=1.0.2
pkgrel=1
pkgdesc="a lightweight audio mixer which lets you control the audio volume through a tray icon"
-url="http://sourceforge.net/projects/gvolwheel/"
+url="https://github.com/Junker/gvolwheel"
arch=('i686' 'x86_64')
license=('GPL-2')
-makedepends=('perlxml')
-depends=('gtk3')
makedepends=('intltool')
-source=("http://downloads.sourceforge.net/${pkgname}/${pkgname}-${pkgver}.tar.gz")
-md5sums=('4f04f00cdb875894c96b8a3ff8a9edb9')
+depends=('gtk3' 'libgee')
+source=("https://github.com/Junker/${pkgname}/archive/${pkgver}.zip")
+md5sums=('2bfde9ec2d9f288531626c1688c6b025')
build() {
-cd $srcdir/${pkgname}-$pkgver
-./configure --prefix=/usr --docdir=/usr/share/doc/gvolwheel
-# setting docdir is ineffective
-sed -i '/gvolwheeldocdir/s/doc\//share\/doc\//' Makefile
-make
+ cd $srcdir/${pkgname}-$pkgver
+ ./autogen.sh --prefix=/usr
+ ./configure --prefix=/usr
+ make
}
package() {
-cd $srcdir/${pkgname}-$pkgver
-make DESTDIR=${pkgdir} install
+ cd $srcdir/${pkgname}-$pkgver
+ make DESTDIR="$pkgdir" install
}