summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD12
-rw-r--r--libnotify-0.8.patch11
3 files changed, 23 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5f5b927ba140..d2ec218fe073 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gwe
pkgdesc = A system utility for controlling NVIDIA GPUs
pkgver = 0.15.5
- pkgrel = 1
+ pkgrel = 2
url = https://gitlab.com/leinardi/gwe
arch = any
license = GPL3
@@ -10,6 +10,7 @@ pkgbase = gwe
depends = gobject-introspection
depends = libdazzle
depends = libappindicator-gtk3
+ depends = libnotify
depends = python
depends = python-cairo
depends = python-gobject
@@ -22,6 +23,8 @@ pkgbase = gwe
depends = python-pyxdg
depends = python-xlib
source = https://gitlab.com/leinardi/gwe/-/archive/0.15.5/gwe-0.15.5.tar.gz
+ source = libnotify-0.8.patch
sha256sums = 67c30c735b6160c2f4af61ce353108dc9709b6c850ce8bc21d2d2a506dfa3b70
+ sha256sums = 9db823f5eda05ad7f1b10b8a1d69437efe89cf00b6001fc15b15c049d84385ce
pkgname = gwe
diff --git a/PKGBUILD b/PKGBUILD
index 25568fba5ced..5bbb6e66ef1c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,25 @@
pkgname=gwe
pkgver=0.15.5
-pkgrel=1
+pkgrel=2
pkgdesc="A system utility for controlling NVIDIA GPUs"
arch=('any')
url="https://gitlab.com/leinardi/gwe"
license=('GPL3')
-depends=('gobject-introspection' 'libdazzle' 'libappindicator-gtk3' 'python' 'python-cairo' 'python-gobject' 'python-injector' 'python-matplotlib' 'python-peewee' 'python-py3nvml' 'python-requests' 'python-rx' 'python-pyxdg' 'python-xlib')
+depends=('gobject-introspection' 'libdazzle' 'libappindicator-gtk3' 'libnotify' 'python' 'python-cairo' 'python-gobject' 'python-injector' 'python-matplotlib' 'python-peewee' 'python-py3nvml' 'python-requests' 'python-rx' 'python-pyxdg' 'python-xlib')
makedepends=('meson' 'appstream-glib')
provides=()
-source=("https://gitlab.com/leinardi/gwe/-/archive/$pkgver/$pkgname-$pkgver.tar.gz")
-sha256sums=('67c30c735b6160c2f4af61ce353108dc9709b6c850ce8bc21d2d2a506dfa3b70')
+source=("https://gitlab.com/leinardi/gwe/-/archive/$pkgver/$pkgname-$pkgver.tar.gz"
+ "libnotify-0.8.patch")
+sha256sums=('67c30c735b6160c2f4af61ce353108dc9709b6c850ce8bc21d2d2a506dfa3b70'
+ '9db823f5eda05ad7f1b10b8a1d69437efe89cf00b6001fc15b15c049d84385ce')
build() {
if [[ -d "$srcdir/build" ]]; then
rm -rf "$srcdir/build"
fi
+ # patch the required version of libnotify to 0.8
+ patch -p1 -d "$pkgname-$pkgver" -i ../libnotify-0.8.patch
meson --prefix /usr --buildtype=plain "$pkgname-$pkgver" build
ninja -C build
}
diff --git a/libnotify-0.8.patch b/libnotify-0.8.patch
new file mode 100644
index 000000000000..bce828cd646f
--- /dev/null
+++ b/libnotify-0.8.patch
@@ -0,0 +1,11 @@
+--- a/bin/gwe.in
++++ b/bin/gwe.in
+@@ -44,7 +44,7 @@
+ gi.require_version('Gtk', '3.0')
+ gi.require_version('Dazzle', '1.0')
+ gi.require_version('Gdk', '3.0')
+- gi.require_version('Notify', '0.7')
++ gi.require_version('Notify', '0.8')
+
+ from gi.repository import Gio
+ resource = Gio.Resource.load(os.path.join(PKGDATA_DIR, 'com.leinardi.gwe.gresource'))