summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO29
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD59
-rw-r--r--gweled-c99.patch19
-rw-r--r--gweled-fix-librsvg-segfault-v2.patch50
-rw-r--r--gweled.appdata.xml23
-rw-r--r--gweled.install19
7 files changed, 27 insertions, 175 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2d1b9456a0d4..91242ee9edda 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,17 @@
pkgbase = gweled
- pkgdesc = A puzzle game similar to Bejeweled (aka Diamond Mine)
- pkgver = 0.9.1
- pkgrel = 6
+ pkgdesc = A puzzle game similar to Bejeweled or Diamond Mine
+ pkgver = 1.0.beta1
+ pkgrel = 1
url = https://gweled.org
- install = gweled.install
arch = x86_64
license = GPL-2.0-or-later
- makedepends = git
- makedepends = intltool
- depends = gtk2
- depends = hicolor-icon-theme
- depends = librsvg
- depends = sdl_mixer
- source = git+https://github.com/Marisa-Chan/gweled-sdl_mixer.git#commit=819bede9b80860c49eb7666c163bfe42f21dd2c6
- source = gweled-fix-librsvg-segfault-v2.patch
- source = gweled-c99.patch
- source = gweled.appdata.xml
- sha256sums = SKIP
- sha256sums = 61f483bde4bfafc4e964da990e34f82f94861c2d7318efb4c52b998b52b92045
- sha256sums = d7d09017527c0eb44c311e105f1b1106dcbffd9c0711736ed680a371deb69c81
- sha256sums = 987567fac9026edb06493a7be7de522a625f224aa7d31684846bbacfd770ad7c
+ checkdepends = appstream-glib
+ makedepends = meson
+ depends = clutter-gtk
+ depends = gsound
+ depends = gtk3
+ depends = libgnome-games-support
+ source = https://launchpad.net/gweled/1.0/1.0-beta1/+download/gweled-1.0-beta1.tar.xz
+ sha256sums = f4930b1ebb4ecc8f7a021a3b185a668e9ec26a0dcdb9b361a00edbad557e9f62
pkgname = gweled
diff --git a/.gitignore b/.gitignore
index 8f54f141d061..4dab8d6386e3 100644
--- a/.gitignore
+++ b/.gitignore
@@ -5,6 +5,3 @@
!.gitignore
!PKGBUILD
!.SRCINFO
-!gweled-fix-librsvg-segfault-v2.patch
-!gweled-c99.patch
-!gweled.appdata.xml
diff --git a/PKGBUILD b/PKGBUILD
index d6ba9ac952ff..80bb3591f034 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,55 +1,28 @@
# Maintainer: Mark Wagie <mark dot wagie at proton dot me>
# Contributor: Eric BĂ©langer <eric@archlinux.org>
pkgname=gweled
-pkgver=0.9.1
-pkgrel=6
-pkgdesc="A puzzle game similar to Bejeweled (aka Diamond Mine)"
+_pkgver=1.0-beta1
+pkgver=${_pkgver//-/.}
+pkgrel=1
+pkgdesc="A puzzle game similar to Bejeweled or Diamond Mine"
arch=('x86_64')
-license=('GPL-2.0-or-later')
url="https://gweled.org"
-depends=('gtk2' 'hicolor-icon-theme' 'librsvg' 'sdl_mixer')
-makedepends=('git' 'intltool')
-install="$pkgname.install"
-_commit=819bede9b80860c49eb7666c163bfe42f21dd2c6
-#source=("https://launchpad.net/gweled/trunk/$pkgver/+download/$pkgname-$pkgver.tar.gz"
-# Fork using sdl_mixer rather than libcanberra or libmikmod
-source=("git+https://github.com/Marisa-Chan/gweled-sdl_mixer.git#commit=$_commit"
- "$pkgname-fix-librsvg-segfault-v2.patch"
- "$pkgname-c99.patch"
- "$pkgname.appdata.xml")
-sha256sums=('SKIP'
- '61f483bde4bfafc4e964da990e34f82f94861c2d7318efb4c52b998b52b92045'
- 'd7d09017527c0eb44c311e105f1b1106dcbffd9c0711736ed680a371deb69c81'
- '987567fac9026edb06493a7be7de522a625f224aa7d31684846bbacfd770ad7c')
+license=('GPL-2.0-or-later')
+depends=('clutter-gtk' 'gsound' 'gtk3' 'libgnome-games-support')
+makedepends=('meson')
+checkdepends=('appstream-glib')
+source=("https://launchpad.net/gweled/1.0/${_pkgver}/+download/$pkgname-${_pkgver}.tar.xz")
+sha256sums=('f4930b1ebb4ecc8f7a021a3b185a668e9ec26a0dcdb9b361a00edbad557e9f62')
-prepare() {
- cd "$srcdir/$pkgname-sdl_mixer"
- patch -Np0 -i ../"$pkgname-fix-librsvg-segfault-v2.patch"
- patch -Np1 -i ../"$pkgname-c99.patch"
+build() {
+ arch-meson "$pkgname-${_pkgver}" build
+ meson compile -C build
}
-build() {
- cd "$srcdir/$pkgname-sdl_mixer"
- export LDFLAGS="${LDFLAGS} -lm -Wl,--export-dynamic "
- ./autogen.sh
- ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
- --with-scores-user=root --with-scores-group=games
- make
+check() {
+ meson test -C build --print-errorlogs
}
package() {
- cd "$srcdir/$pkgname-sdl_mixer"
- make DESTDIR="$pkgdir" install
-
- # Register as an application to be visible in the software center
- #
- # NOTE: It would be *awesome* if this file was maintained by the upstream
- # project, translated and installed into the right place during `make install`.
- #
- # See http://www.freedesktop.org/software/appstream/docs/ for more details.
- #
- install -Dm644 "$srcdir/$pkgname.appdata.xml" -t "$pkgdir/usr/share/appdata/"
-
- # We generate these files on post-install to prevent score resets on upgrade
- rm -rf "$pkgdir/var"
+ meson install -C build --destdir "$pkgdir"
}
diff --git a/gweled-c99.patch b/gweled-c99.patch
deleted file mode 100644
index 740f1d2babd3..000000000000
--- a/gweled-c99.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-commit 033834d6db19ddcc7856e40895eb7c4e44b3d5d4
-Author: Stephen Kitt <skitt@debian.org>
-Date: Thu Feb 11 19:59:37 2021 +0100
-
- Add missing init_pref_window declaration
-
-diff --git a/src/board_engine.c b/src/board_engine.c
-index e5a991ee276537d7..09a59dd1351357e1 100644
---- a/src/board_engine.c
-+++ b/src/board_engine.c
-@@ -978,6 +978,8 @@ GweledGameState gweled_get_current_game(void)
- return game;
- }
-
-+extern void init_pref_window(void);
-+
- void gweled_set_previous_game(GweledGameState game)
- {
- gchar *text_buffer;
diff --git a/gweled-fix-librsvg-segfault-v2.patch b/gweled-fix-librsvg-segfault-v2.patch
deleted file mode 100644
index 5a36bcdb1d8f..000000000000
--- a/gweled-fix-librsvg-segfault-v2.patch
+++ /dev/null
@@ -1,50 +0,0 @@
-=== modified file 'src/sge_utils.c'
---- src/sge_utils.c 2011-08-01 21:29:27 +0000
-+++ src/sge_utils.c 2018-02-05 07:39:25 +0000
-@@ -18,6 +18,7 @@
- * Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
- */
-
-+#include <gio/gio.h>
- #include <gtk/gtk.h>
- #include <librsvg/rsvg.h>
-
-@@ -30,7 +31,8 @@
- {
- gchar *full_pathname;
- GdkPixbuf *pixbuf = NULL;
-- GError *error;
-+ GError *error = NULL;
-+ GFile *file;
-
- full_pathname = g_strconcat(DATADIR "/pixmaps/",
- filename,
-@@ -38,13 +40,25 @@
- if (g_file_test(full_pathname, G_FILE_TEST_IS_REGULAR)) {
- pixbuf = rsvg_pixbuf_from_file_at_size (full_pathname, width,
- height, &error);
-- g_free (full_pathname);
-+ if (pixbuf == NULL) {
-+ // Some versions of librsvg need URI instead of path.
-+ // https://gitlab.gnome.org/GNOME/librsvg/issues/198
-+ g_clear_error (&error);
-+ file = g_file_new_for_path (full_pathname);
-+ g_free (full_pathname);
-+ full_pathname = g_file_get_uri (file);
-+ g_object_unref (file);
-+ pixbuf = rsvg_pixbuf_from_file_at_size (full_pathname, width,
-+ height, &error);
-+ }
- if (pixbuf == NULL)
-- g_free (error);
-+ g_error_free (error);
-
- } else
- g_warning ("%s not found", filename);
-
-+ g_free (full_pathname);
-+
- return pixbuf;
- }
-
-
diff --git a/gweled.appdata.xml b/gweled.appdata.xml
deleted file mode 100644
index b83ad6b35b95..000000000000
--- a/gweled.appdata.xml
+++ /dev/null
@@ -1,23 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!-- Copyright 2014 William Moreno <williamjmorenor@fedoraproject.org> -->
-<!--
-BugReportURL: https://bugs.launchpad.net/gweled/+bug/1322917
-SentUpstream: 2014-06-12
--->
-<application>
- <id type="desktop">gweled.desktop</id>
- <metadata_license>CC0-1.0</metadata_license>
- <summary>Align three identical gems to remove them from board</summary>
- <description>
- <p>
- Gweled is a version for GNU / Linux of the popular mobile game called
- Bejeweled or Diamond Mine.
- The game consist in to move adjacent gems to align three or more vertically
- or horizontally to remove them from the board.
- </p>
- </description>
- <url type="homepage">http://launchpad.net/gweled</url>
- <screenshots>
- <screenshot type="default">http://gweled.org/images/screen1.png</screenshot>
- </screenshots>
-</application>
diff --git a/gweled.install b/gweled.install
deleted file mode 100644
index 9be6ea940abe..000000000000
--- a/gweled.install
+++ /dev/null
@@ -1,19 +0,0 @@
-scores=(
- 'gweled.Normal.scores'
- 'gweled.Timed.scores'
-)
-
-post_install() {
- for score in "${scores[@]}" ; do
- if [ -e "var/games/${score}" ]; then
- continue
- fi
- touch "var/games/${score}"
- chown root:games "var/games/${score}"
- chmod 664 "var/games/${score}"
- done
-}
-
-post_upgrade() {
- post_install $1
-}