summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD29
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..770075c11c51
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = gwion-git
+ pkgdesc = a strongly timed musical programming language
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/fennecdjay/gwion
+ arch = any
+ license = GPL3
+ makedepends = git
+ provides = gwion-git
+ conflicts = gwion
+ source = git+https://github.com/fennecdjay/gwion
+ md5sums = SKIP
+
+pkgname = gwion-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f8680ca446f8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Jérémie Astor <astor.jeremie@wanadoo.fr>
+pkgname=gwion-git
+pkgver=0.1
+pkgrel=1
+pkgdesc="a strongly timed musical programming language"
+arch=('any')
+url="https://github.com/fennecdjay/gwion"
+license=('GPL3')
+makedepends=('git')
+provides=("${pkgname}")
+conflicts=("${pkgname%-git}")
+source=('git+https://github.com/fennecdjay/gwion')
+md5sums=('SKIP')
+
+prepare() {
+ cd "$srcdir/${pkgname%-git}"
+ git clone https://github.com/fennecdjay/gwion-util util
+ git clone https://github.com/fennecdjay/gwion-ast ast
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ make PREFIX="" DESTDIR="$pkgdir/" install
+}