summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD43
2 files changed, 33 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1901e4c7e4c1..59d99f32eb9c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,15 @@
-# Generated by mksrcinfo v8
-# Tue Feb 27 11:25:21 UTC 2018
pkgbase = gx-go
- pkgdesc = A tool to use with the gx package manager for packages written in go.
- pkgver = 1.6.0
- pkgrel = 1
+ pkgdesc = A tool to use with the gx package manager for packages written in go
+ pkgver = 1.9.0
+ pkgrel = 2
url = https://github.com/whyrusleeping/gx-go
- arch = i686
arch = x86_64
- arch = armv7h
license = MIT
+ makedepends = git
+ makedepends = go-pie
depends = glibc
- source_i686 = https://ipfs.io/ipns/dist.ipfs.io/gx-go/v1.6.0/gx-go_v1.6.0_linux-386.tar.gz
- sha512sums_i686 = 3177e9232a96070d7898cfeb513c445d484a139e184411edf8a633b16e2cf5fbbc3136ea8c4c406367d15b9685e9c5c0789ae59a3758b6881be39a890aed9f3e
- source_x86_64 = https://ipfs.io/ipns/dist.ipfs.io/gx-go/v1.6.0/gx-go_v1.6.0_linux-amd64.tar.gz
- sha512sums_x86_64 = 9654000bcfa14193eeb353811c1333064aeb387162c8faa4037147dbdc16db3176d754cc17171b36f5102847823f6da2063573f9cc78dcec0569ec6decc413dc
- source_armv7h = https://ipfs.io/ipns/dist.ipfs.io/gx-go/v1.6.0/gx-go_v1.6.0_linux-arm.tar.gz
- sha512sums_armv7h = 8486951b90ac70681c86fa87933633cedf591a0933200dbb2372138005b26b0ddd72954a47290c2efb6ee34978806773898f9bc03d5c5cb1909b341120e74a18
+ source = git+https://github.com/whyrusleeping/gx-go.git#tag=v1.9.0
+ md5sums = SKIP
pkgname = gx-go
diff --git a/PKGBUILD b/PKGBUILD
index 65ee7bc390dd..49ad6df74e4f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,37 @@
-# Maintainer: Jakub "Kubuxu" Sztandera <kubuxu@protonmail.ch>
-# vim: set expandtab ts=2 sw=2:
+# Maintainer: Johannes Löthberg <johannes@kyriasis.com>
+# Contributor: Jakub "Kubuxu" Sztandera <kubuxu@protonmail.ch>
pkgname=gx-go
-pkgver=1.6.0
-pkgrel=1
+pkgver=1.9.0
+pkgrel=2
-pkgdesc="A tool to use with the gx package manager for packages written in go."
-url="https://github.com/whyrusleeping/$pkgname"
-arch=('i686' 'x86_64' 'armv7h')
+pkgdesc="A tool to use with the gx package manager for packages written in go"
+url="https://github.com/whyrusleeping/gx-go"
+arch=('x86_64')
license=('MIT')
+makedepends=('git' 'go-pie')
depends=('glibc')
-optdepends=()
-makedepends=()
-_srcroot="https://ipfs.io/ipns/dist.ipfs.io"
-source_x86_64=("$_srcroot/$pkgname/v$pkgver/${pkgname}_v${pkgver}_linux-amd64.tar.gz")
-source_i686=("$_srcroot/$pkgname/v$pkgver/${pkgname}_v${pkgver}_linux-386.tar.gz")
-source_armv7h=("$_srcroot/$pkgname/v$pkgver/${pkgname}_v${pkgver}_linux-arm.tar.gz")
+source=("git+https://github.com/whyrusleeping/gx-go.git#tag=v$pkgver")
+md5sums=('SKIP')
-sha512sums_i686=('3177e9232a96070d7898cfeb513c445d484a139e184411edf8a633b16e2cf5fbbc3136ea8c4c406367d15b9685e9c5c0789ae59a3758b6881be39a890aed9f3e')
-sha512sums_x86_64=('9654000bcfa14193eeb353811c1333064aeb387162c8faa4037147dbdc16db3176d754cc17171b36f5102847823f6da2063573f9cc78dcec0569ec6decc413dc')
-sha512sums_armv7h=('8486951b90ac70681c86fa87933633cedf591a0933200dbb2372138005b26b0ddd72954a47290c2efb6ee34978806773898f9bc03d5c5cb1909b341120e74a18')
+prepare() {
+ mkdir -p "$srcdir"/src/github.com/whyrusleeping/
+ ln -fs "$srcdir/gx-go" "$srcdir"/src/github.com/whyrusleeping/gx-go
+}
+
+build() {
+ # Required for go get
+ export GOPATH="$srcdir"
+ export GOBIN="$GOPATH/bin"
+ cd "$srcdir"/src/github.com/whyrusleeping/gx-go
+
+ go get -v
+ go install -v
+}
package() {
- install -Dm 755 ${pkgname}/${pkgname} "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm 755 bin/gx-go "${pkgdir}/usr/bin/gx-go"
+ install -Dm 644 -t "${pkgdir}/usr/share/licenses/gx-go" gx-go/LICENSE
}