summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD48
3 files changed, 25 insertions, 43 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d16134457628..f969d929d212 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,21 @@
# Generated by mksrcinfo v8
-# Wed Aug 24 21:04:57 UTC 2016
+# Sun Apr 23 12:51:17 UTC 2017
pkgbase = gx-go
pkgdesc = A tool to use with the gx package manager for packages written in go.
- pkgver = 1.3.0.r0.g3cbfcbb
+ pkgver = 1.4.0
pkgrel = 1
url = https://github.com/whyrusleeping/gx-go
arch = i686
arch = x86_64
arch = armv7h
license = MIT
- makedepends = git
- makedepends = go
- depends = gx
- source = git+https://github.com/whyrusleeping/gx-go.git
- md5sums = SKIP
+ depends = glibc
+ source_i686 = https://ipfs.io/ipns/dist.ipfs.io/gx-go/v1.4.0/gx-go_v1.4.0_linux-386.tar.gz
+ sha512sums_i686 = b15942da2e5408c5f1048f3a4163afca7efbadbe90fb0eec329cd107cf2d4eb4a4506edcd3b5cffccafd113f2dd0c23019ccb45f1ecf47a3fd8ef9317d53321a
+ source_x86_64 = https://ipfs.io/ipns/dist.ipfs.io/gx-go/v1.4.0/gx-go_v1.4.0_linux-amd64.tar.gz
+ sha512sums_x86_64 = c657e8855c362149893da441f1e1592f6ca8e6b84cefe5bebd3a41140148e52dacc0cfc0a933629d0e5fbf257009afa6014d9a0ef0fca33452d8be03b8adf6e9
+ source_armv7h = https://ipfs.io/ipns/dist.ipfs.io/gx-go/v1.4.0/gx-go_v1.4.0_linux-arm.tar.gz
+ sha512sums_armv7h = bed1059577f0bdf2a047850978293fb00e4dacf932cf6a515b35fe5f8cef2281fecc8de4da34cf8f678730146b2079e5de4cfc9069091b1e2ee47a4011931153
pkgname = gx-go
diff --git a/.gitignore b/.gitignore
index f6fa8ae771cb..d4d63621e3e3 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1,3 @@
-gx-go
-gx-go-*
+gx-go*
src
+pkg
diff --git a/PKGBUILD b/PKGBUILD
index 11df77aa28af..83b0e2b8877d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,47 +2,27 @@
# vim: set expandtab ts=2 sw=2:
pkgname=gx-go
-pkgver=1.3.0.r0.g3cbfcbb
+pkgver=1.4.0
pkgrel=1
-epoch=
+
pkgdesc="A tool to use with the gx package manager for packages written in go."
-arch=('i686' 'x86_64' 'armv7h')
url="https://github.com/whyrusleeping/$pkgname"
+arch=('i686' 'x86_64' 'armv7h')
license=('MIT')
-depends=('gx')
-makedepends=('git' 'go')
-source=("git+${url}.git")
-md5sums=('SKIP')
-pkgver() {
- # Renable after tags are placed in the repo.
- cd "$srcdir/$pkgname"
- git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
-}
+depends=('glibc')
+optdepends=()
+makedepends=()
-prepare() {
- mkdir -p "$srcdir"/src/github.com/whyrusleeping/
- ln -fs "$srcdir/$pkgname" "$srcdir"/src/github.com/whyrusleeping/"$pkgname"
-}
+_srcroot="https://ipfs.io/ipns/dist.ipfs.io"
+source_x86_64=("$_srcroot/$pkgname/v$pkgver/${pkgname}_v${pkgver}_linux-amd64.tar.gz")
+source_i686=("$_srcroot/$pkgname/v$pkgver/${pkgname}_v${pkgver}_linux-386.tar.gz")
+source_armv7h=("$_srcroot/$pkgname/v$pkgver/${pkgname}_v${pkgver}_linux-arm.tar.gz")
-build() {
- # Required for go get
- export GOPATH="$srcdir"
- export GOBIN="$GOPATH/bin"
- cd "$srcdir"/src/github.com/whyrusleeping/"$pkgname"
-
- msg2 'Installing dependencies...'
- go get -v
-
- msg2 'Building binary...'
- go install -v
-}
+sha512sums_i686=('b15942da2e5408c5f1048f3a4163afca7efbadbe90fb0eec329cd107cf2d4eb4a4506edcd3b5cffccafd113f2dd0c23019ccb45f1ecf47a3fd8ef9317d53321a')
+sha512sums_x86_64=('c657e8855c362149893da441f1e1592f6ca8e6b84cefe5bebd3a41140148e52dacc0cfc0a933629d0e5fbf257009afa6014d9a0ef0fca33452d8be03b8adf6e9')
+sha512sums_armv7h=('bed1059577f0bdf2a047850978293fb00e4dacf932cf6a515b35fe5f8cef2281fecc8de4da34cf8f678730146b2079e5de4cfc9069091b1e2ee47a4011931153')
package() {
- msg2 'Packaging binary...'
- install -Dm 755 bin/gx-go "${pkgdir}/usr/bin/gx-go"
-
- msg2 'Packaging auxiliary files...'
- cd "$pkgname"
- install -Dm 644 -t "${pkgdir}/usr/share/licenses/${pkgname}" LICENSE
+ install -Dm 755 ${pkgname}/${pkgname} "${pkgdir}/usr/bin/${pkgname}"
}