summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD33
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8c29f75be610
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by makepkg 4.2.1
+# Sat Jun 27 17:23:57 UTC 2015
+pkgbase = gyazo-git
+ pkgdesc = Launch the Gyazo app and drag your mouse to grab the screen.
+ pkgver = 1.0
+ pkgrel = 1
+ url = http://gyazo.com
+ arch = any
+ groups = multimedia
+ license = GPL
+ makedepends = git
+ depends = ruby
+ depends = xclip
+ depends = imagemagick
+ conflicts = gyazo
+
+pkgname = gyazo-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ef9555a8a119
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: procrastinator
+pkgname=gyazo-git
+pkgver=1.0
+pkgrel=1
+pkgdesc="Launch the Gyazo app and drag your mouse to grab the screen."
+arch=('any')
+url="http://gyazo.com"
+license=('GPL')
+groups=(multimedia)
+depends=('ruby' 'xclip' 'imagemagick')
+makedepends=('git')
+conflicts=('gyazo')
+
+_gitremote="https://github.com/gyazo/Gyazo-for-Linux.git"
+_gitname="Gyazo-for-Linux"
+
+build() {
+ cd "$srcdir"
+ if [ -d $_gitname ] ; then
+ git pull origin
+ msg "Local repository updated."
+ else
+ git clone $_gitremote $_gitname
+ fi
+}
+
+package() {
+ install -D -m755 "$srcdir/$_gitname/src/gyazo.rb" "$pkgdir/usr/bin/gyazo"
+ install -D -m664 "$srcdir/$_gitname/src/gyazo.desktop" "$pkgdir/usr/share/applications/gyazo.desktop"
+ install -D -m644 "$srcdir/$_gitname/icons/gyazo.png" "$pkgdir/usr/share/pixmaps/gyazo.png"
+
+}
+