summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO33
-rw-r--r--0001-Fix-file-paths.patch47
-rw-r--r--0001-Fix-soundfont-search-path.patch33
-rw-r--r--PKGBUILD102
4 files changed, 103 insertions, 112 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 864818904580..d3c1874354bd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,52 +1,49 @@
pkgbase = gzdoom
- pkgdesc = Advanced Doom source port with OpenGL support
- pkgver = 4.2.0
- pkgrel = 1
+ pkgdesc = Feature centric port for all Doom engine games
+ pkgver = 4.11.3
+ pkgrel = 2
url = http://www.zdoom.org/
arch = i686
arch = x86_64
+ arch = aarch64
license = BSD
- license = custom:dumb
license = GPL3
license = LGPL3
makedepends = cmake
makedepends = desktop-file-utils
- makedepends = fluidsynth>=2
makedepends = git
- makedepends = gtk3
+ depends = gtk3
depends = hicolor-icon-theme
depends = libgl
- depends = libjpeg
+ depends = libvpx>=1.14
+ depends = libwebp
+ depends = openal
depends = sdl2
+ depends = zmusic>=1.1.8
optdepends = blasphemer-wad: Blasphemer (free Heretic) game data
optdepends = chexquest3-wad: Chex Quest 3 game data
optdepends = doom1-wad: Doom shareware game data
- optdepends = fluidsynth>=2: FluidSynth MIDI device
optdepends = freedm: FreeDM game data
- optdepends = freedoom1: Freedoom: Phase 1 game data
- optdepends = freedoom2: Freedoom: Phase 2 game data
- optdepends = gtk3: IWAD selection dialog
+ optdepends = freedoom: Freedoom game data
optdepends = gxmessage: crash dialog (GNOME)
optdepends = hacx-wad: HacX game data
optdepends = harmony-wad: Harmony game data
optdepends = heretic1-wad: Heretic shareware game data
optdepends = hexen1-wad: Hexen demo game data
optdepends = kdialog: crash dialog (KDE)
- optdepends = libsndfile: WAV/FLAC/OGG audio support
- optdepends = mpg123: MP3 audio support
- optdepends = openal: in-game sound
- optdepends = soundfont-fluid: FluidR3 soundfont for FluidSynth
optdepends = strife0-wad: Strife shareware game data
optdepends = square1-wad: The Adventures of Square, Episode 1 game data
optdepends = urbanbrawl-wad: Urban Brawl: Action Doom 2 game data
optdepends = xorg-xmessage: crash dialog (other)
replaces = gzdoom1
- source = gzdoom::git://github.com/coelckers/gzdoom.git#tag=g4.2.0
+ replaces = gzdoom-legacy
+ options = !lto
+ source = gzdoom::git+https://github.com/coelckers/gzdoom.git#tag=g4.11.3
source = gzdoom.desktop
- source = 0001-Fix-soundfont-search-path.patch
+ source = 0001-Fix-file-paths.patch
sha256sums = SKIP
sha256sums = 59122e670f72aa2531aff370e7aaab2d886a7642e79e91f27a533d3b4cad4f6d
- sha256sums = 11323f98caadb086b35cce1697744eeba53c96a3f4f9a8c9184ed23e6fb1ea61
+ sha256sums = a37dde8274e1a9fd511af951da2e362d503ab4be72e79d4843e1ca3a0129549f
optdepends_x86_64 = vulkan-driver: Vulkan renderer
optdepends_x86_64 = vulkan-icd-loader: Vulkan renderer
diff --git a/0001-Fix-file-paths.patch b/0001-Fix-file-paths.patch
new file mode 100644
index 000000000000..5df3f66c809e
--- /dev/null
+++ b/0001-Fix-file-paths.patch
@@ -0,0 +1,47 @@
+From 749acb5c34edad113b083e37df034887674aad3e Mon Sep 17 00:00:00 2001
+From: Jan Cholasta <jan@cholasta.net>
+Date: Tue, 25 Feb 2020 12:53:07 +0100
+Subject: [PATCH] Fix file paths
+
+---
+ src/gameconfigfile.cpp | 10 ++--------
+ 1 file changed, 2 insertions(+), 8 deletions(-)
+
+diff --git a/src/gameconfigfile.cpp b/src/gameconfigfile.cpp
+index 82b8071b60..a6584fa6f5 100644
+--- a/src/gameconfigfile.cpp
++++ b/src/gameconfigfile.cpp
+@@ -121,8 +121,6 @@ FGameConfigFile::FGameConfigFile ()
+ // Arch Linux likes them in /usr/share/doom
+ // Debian likes them in /usr/share/games/doom
+ // I assume other distributions don't do anything radically different
+- SetValueForKey ("Path", "/usr/local/share/doom", true);
+- SetValueForKey ("Path", "/usr/local/share/games/doom", true);
+ SetValueForKey ("Path", "/usr/share/doom", true);
+ SetValueForKey ("Path", "/usr/share/games/doom", true);
+ #endif
+@@ -143,8 +141,6 @@ FGameConfigFile::FGameConfigFile ()
+ SetValueForKey ("Path", "$HOME/" GAME_DIR, true);
+ SetValueForKey ("Path", "$HOME/.local/share/games/doom", true);
+ SetValueForKey ("Path", SHARE_DIR, true);
+- SetValueForKey ("Path", "/usr/local/share/doom", true);
+- SetValueForKey ("Path", "/usr/local/share/games/doom", true);
+ SetValueForKey ("Path", "/usr/share/doom", true);
+ SetValueForKey ("Path", "/usr/share/games/doom", true);
+ #endif
+@@ -172,10 +168,8 @@ FGameConfigFile::FGameConfigFile ()
+ SetValueForKey("Path", "$HOME/" GAME_DIR "/fm_banks", true);
+ SetValueForKey("Path", "$HOME/.local/share/games/doom/soundfonts", true);
+ SetValueForKey("Path", "$HOME/.local/share/games/doom/fm_banks", true);
+- SetValueForKey("Path", "/usr/local/share/doom/soundfonts", true);
+- SetValueForKey("Path", "/usr/local/share/doom/fm_banks", true);
+- SetValueForKey("Path", "/usr/local/share/games/doom/soundfonts", true);
+- SetValueForKey("Path", "/usr/local/share/games/doom/fm_banks", true);
++ SetValueForKey("Path", "$PROGDIR/soundfonts", true);
++ SetValueForKey("Path", "$PROGDIR/fm_banks", true);
+ SetValueForKey("Path", "/usr/share/doom/soundfonts", true);
+ SetValueForKey("Path", "/usr/share/doom/fm_banks", true);
+ SetValueForKey("Path", "/usr/share/games/doom/soundfonts", true);
+--
+2.38.1
+
diff --git a/0001-Fix-soundfont-search-path.patch b/0001-Fix-soundfont-search-path.patch
deleted file mode 100644
index 0c1ac9da73fd..000000000000
--- a/0001-Fix-soundfont-search-path.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-From c70f3a7973eef99c6709f11be75d7fe1bdc29efd Mon Sep 17 00:00:00 2001
-From: Jan Cholasta <jan@cholasta.net>
-Date: Mon, 5 Mar 2018 16:17:24 +0100
-Subject: [PATCH] Fix soundfont search path
-
----
- src/gameconfigfile.cpp | 3 +++
- 1 file changed, 3 insertions(+)
-
-diff --git a/src/gameconfigfile.cpp b/src/gameconfigfile.cpp
-index 2979420f9..c8f22895c 100644
---- a/src/gameconfigfile.cpp
-+++ b/src/gameconfigfile.cpp
-@@ -149,6 +149,8 @@ FGameConfigFile::FGameConfigFile ()
- #else
- SetValueForKey("Path", "$HOME/" GAME_DIR "/soundfonts", true);
- SetValueForKey("Path", "$HOME/" GAME_DIR "/fm_banks", true);
-+ SetValueForKey("Path", SHARE_DIR "/soundfonts", true);
-+ SetValueForKey("Path", SHARE_DIR "/fm_banks", true);
- SetValueForKey("Path", "/usr/local/share/doom/soundfonts", true);
- SetValueForKey("Path", "/usr/local/share/doom/fm_banks", true);
- SetValueForKey("Path", "/usr/local/share/games/doom/soundfonts", true);
-@@ -157,6 +159,7 @@ FGameConfigFile::FGameConfigFile ()
- SetValueForKey("Path", "/usr/share/doom/fm_banks", true);
- SetValueForKey("Path", "/usr/share/games/doom/soundfonts", true);
- SetValueForKey("Path", "/usr/share/games/doom/fm_banks", true);
-+ SetValueForKey("Path", "/usr/share/soundfonts", true);
- #endif
- }
-
---
-2.19.0
-
diff --git a/PKGBUILD b/PKGBUILD
index 8fce52eb11e7..25917a714f08 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,94 +1,74 @@
# Maintainer: Jan Cholasta <grubber at grubber cz>
# Contributor: Christoph Zeiler <rabyte*gmail>
-_name=gzdoom
-pkgname=${_name}
-pkgver=4.2.0
-pkgrel=1
-pkgdesc='Advanced Doom source port with OpenGL support'
-arch=('i686' 'x86_64')
+pkgname=gzdoom
+pkgver=4.11.3
+pkgrel=2
+pkgdesc='Feature centric port for all Doom engine games'
+arch=('i686' 'x86_64' 'aarch64')
url='http://www.zdoom.org/'
-license=('BSD' 'custom:dumb' 'GPL3' 'LGPL3')
-depends=('hicolor-icon-theme'
+license=('BSD' 'GPL3' 'LGPL3')
+depends=('gtk3'
+ 'hicolor-icon-theme'
'libgl'
- 'libjpeg'
- 'sdl2')
-makedepends=('cmake'
- 'desktop-file-utils'
- 'fluidsynth>=2'
- 'git'
- 'gtk3')
+ 'libvpx>=1.14'
+ 'libwebp'
+ 'openal'
+ 'sdl2'
+ 'zmusic>=1.1.8')
+makedepends=('cmake' 'desktop-file-utils' 'git')
optdepends=('blasphemer-wad: Blasphemer (free Heretic) game data'
'chexquest3-wad: Chex Quest 3 game data'
'doom1-wad: Doom shareware game data'
- 'fluidsynth>=2: FluidSynth MIDI device'
'freedm: FreeDM game data'
- 'freedoom1: Freedoom: Phase 1 game data'
- 'freedoom2: Freedoom: Phase 2 game data'
- 'gtk3: IWAD selection dialog'
+ 'freedoom: Freedoom game data'
'gxmessage: crash dialog (GNOME)'
'hacx-wad: HacX game data'
'harmony-wad: Harmony game data'
'heretic1-wad: Heretic shareware game data'
'hexen1-wad: Hexen demo game data'
'kdialog: crash dialog (KDE)'
- 'libsndfile: WAV/FLAC/OGG audio support'
- 'mpg123: MP3 audio support'
- 'openal: in-game sound'
- 'soundfont-fluid: FluidR3 soundfont for FluidSynth'
'strife0-wad: Strife shareware game data'
'square1-wad: The Adventures of Square, Episode 1 game data'
'urbanbrawl-wad: Urban Brawl: Action Doom 2 game data'
'xorg-xmessage: crash dialog (other)')
optdepends_x86_64=('vulkan-driver: Vulkan renderer'
'vulkan-icd-loader: Vulkan renderer')
-replaces=("${_name}1")
-source=("${_name}::git://github.com/coelckers/${_name}.git#tag=g${pkgver}"
- "${_name}.desktop"
- '0001-Fix-soundfont-search-path.patch')
+replaces=('gzdoom1' 'gzdoom-legacy')
+options=(!lto)
+source=("gzdoom::git+https://github.com/coelckers/gzdoom.git#tag=g${pkgver}"
+ 'gzdoom.desktop'
+ '0001-Fix-file-paths.patch')
sha256sums=('SKIP'
'59122e670f72aa2531aff370e7aaab2d886a7642e79e91f27a533d3b4cad4f6d'
- '11323f98caadb086b35cce1697744eeba53c96a3f4f9a8c9184ed23e6fb1ea61')
+ 'a37dde8274e1a9fd511af951da2e362d503ab4be72e79d4843e1ca3a0129549f')
prepare() {
- cd $_name
-
- patch -p1 -i"$srcdir"/0001-Fix-soundfont-search-path.patch
+ cd gzdoom
+ patch -i "$srcdir"/0001-Fix-file-paths.patch -p 1
}
build() {
- cd $_name
-
- local _cflags="-ffile-prefix-map=\"$PWD\"=. \
- -DSHARE_DIR=\\\"/usr/share/$_name\\\" \
- -DFLUIDSYNTHLIB2=\\\"libfluidsynth.so.2\\\""
- cmake -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_C_FLAGS="${CFLAGS} ${_cflags}" \
- -DCMAKE_CXX_FLAGS="${CXXFLAGS} ${_cflags}" \
- -DCMAKE_EXE_LINKER_FLAGS="${LDFLAGS} -Wl,-z,noexecstack" \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DINSTALL_PATH=bin \
- -DINSTALL_PK3_PATH=share/$_name \
- .
- make
+ cd gzdoom
+ mkdir -p build
+ cmake -B build \
+ -D CMAKE_BUILD_TYPE=Release \
+ -D CMAKE_CXX_FLAGS="$CXXFLAGS -ffile-prefix-map=\"$PWD\"=. -DSHARE_DIR=\\\"/usr/share/gzdoom\\\"" \
+ -D CMAKE_INSTALL_PREFIX=/usr \
+ -D SYSTEMINSTALL=ON \
+ -D INSTALL_PK3_PATH=share/gzdoom \
+ -D INSTALL_SOUNDFONT_PATH=share/gzdoom \
+ -D INSTALL_RPATH=/usr/lib \
+ -D DYN_GTK=OFF \
+ -D DYN_OPENAL=OFF
+ make -C build
}
package() {
- cd $_name
-
- make install DESTDIR="$pkgdir"
- install -D -m644 soundfonts/gzdoom.sf2 \
- "$pkgdir"/usr/share/$_name/soundfonts/gzdoom.sf2
- install -D -m644 fm_banks/GENMIDI.GS.wopl \
- "$pkgdir"/usr/share/$_name/fm_banks/GENMIDI.GS.wopl
- install -D -m644 fm_banks/gs-by-papiezak-and-sneakernets.wopn \
- "$pkgdir"/usr/share/$_name/fm_banks/gs-by-papiezak-and-sneakernets.wopn
-
- desktop-file-install --dir="$pkgdir"/usr/share/applications \
- "$srcdir"/${_name}.desktop
- install -D -m644 src/posix/zdoom.xpm \
- "$pkgdir"/usr/share/icons/hicolor/256x256/apps/${_name}.xpm
-
+ cd gzdoom
+ make -C build install DESTDIR="$pkgdir"
install -d "$pkgdir"/usr/share/licenses
- ln -s /usr/share/doc/$_name/licenses "$pkgdir"/usr/share/licenses/$pkgname
+ mv "$pkgdir"/usr/share/doc/gzdoom/licenses "$pkgdir"/usr/share/licenses/gzdoom
+ desktop-file-install "$srcdir"/gzdoom.desktop --dir="$pkgdir"/usr/share/applications
+ install src/posix/zdoom.xpm -D -m 644 "$pkgdir"/usr/share/icons/hicolor/256x256/apps/gzdoom.xpm
}