summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD18
2 files changed, 13 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d4c14f3a1a2d..cfcd049e228a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
-pkgbase = gzdoom-git
- pkgdesc = Feature centric port for all Doom engine games (git version)
- pkgver = 4.12pre+3+g40ec46e6ea
+pkgbase = gzdoom
+ pkgdesc = Feature centric port for all Doom engine games
+ pkgver = 4.11.0
pkgrel = 1
url = http://www.zdoom.org/
arch = i686
@@ -35,12 +35,10 @@ pkgbase = gzdoom-git
optdepends = square1-wad: The Adventures of Square, Episode 1 game data
optdepends = urbanbrawl-wad: Urban Brawl: Action Doom 2 game data
optdepends = xorg-xmessage: crash dialog (other)
- provides = gzdoom
- conflicts = gzdoom
- replaces = gzdoom1-git
- replaces = gzdoom-legacy-git
+ replaces = gzdoom1
+ replaces = gzdoom-legacy
options = !lto
- source = gzdoom::git+https://github.com/coelckers/gzdoom.git
+ source = gzdoom::git+https://github.com/coelckers/gzdoom.git#tag=g4.11.0
source = gzdoom.desktop
source = 0001-Fix-file-paths.patch
sha256sums = SKIP
@@ -49,5 +47,5 @@ pkgbase = gzdoom-git
optdepends_x86_64 = vulkan-driver: Vulkan renderer
optdepends_x86_64 = vulkan-icd-loader: Vulkan renderer
-pkgname = gzdoom-git
+pkgname = gzdoom
diff --git a/PKGBUILD b/PKGBUILD
index 97e9037459f7..124b32a1546a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
# Maintainer: Jan Cholasta <grubber at grubber cz>
+# Contributor: Christoph Zeiler <rabyte*gmail>
-pkgname=gzdoom-git
-pkgver=4.12pre+3+g40ec46e6ea
+pkgname=gzdoom
+pkgver=4.11.0
pkgrel=1
-pkgdesc='Feature centric port for all Doom engine games (git version)'
+pkgdesc='Feature centric port for all Doom engine games'
arch=('i686' 'x86_64' 'aarch64')
url='http://www.zdoom.org/'
license=('BSD' 'GPL3' 'LGPL3')
@@ -33,22 +34,15 @@ optdepends=('blasphemer-wad: Blasphemer (free Heretic) game data'
'xorg-xmessage: crash dialog (other)')
optdepends_x86_64=('vulkan-driver: Vulkan renderer'
'vulkan-icd-loader: Vulkan renderer')
-provides=('gzdoom')
-conflicts=('gzdoom')
-replaces=('gzdoom1-git' 'gzdoom-legacy-git')
+replaces=('gzdoom1' 'gzdoom-legacy')
options=(!lto)
-source=('gzdoom::git+https://github.com/coelckers/gzdoom.git'
+source=("gzdoom::git+https://github.com/coelckers/gzdoom.git#tag=g${pkgver}"
'gzdoom.desktop'
'0001-Fix-file-paths.patch')
sha256sums=('SKIP'
'59122e670f72aa2531aff370e7aaab2d886a7642e79e91f27a533d3b4cad4f6d'
'a37dde8274e1a9fd511af951da2e362d503ab4be72e79d4843e1ca3a0129549f')
-pkgver() {
- cd gzdoom
- git describe --tags --match '[Gg]*' | sed -r 's/^[Gg]//;s/-/+/g'
-}
-
prepare() {
cd gzdoom
patch -i "$srcdir"/0001-Fix-file-paths.patch -p 1