summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD19
2 files changed, 12 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1ae96c72ad8d..0bef3b12ff8a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
-pkgbase = gzdoom-git
- pkgdesc = Advanced Doom source port with OpenGL support (git version)
- pkgver = 3.6pre+20+ga10f9526b
+pkgbase = gzdoom
+ pkgdesc = Advanced Doom source port with OpenGL support
+ pkgver = 3.5.0
pkgrel = 1
url = http://www.zdoom.org/
arch = i686
@@ -41,15 +41,13 @@ pkgbase = gzdoom-git
optdepends = square1-wad: The Adventures of Square, Episode 1 game data
optdepends = urbanbrawl-wad: Urban Brawl: Action Doom 2 game data
optdepends = xorg-xmessage: crash dialog (other)
- provides = gzdoom
- conflicts = gzdoom
- replaces = gzdoom1-git
- source = gzdoom::git://github.com/coelckers/gzdoom.git
+ replaces = gzdoom1
+ source = gzdoom::git://github.com/coelckers/gzdoom.git#tag=g3.5.0
source = gzdoom.desktop
source = 0001-Fix-soundfont-search-path.patch
sha256sums = SKIP
sha256sums = 59122e670f72aa2531aff370e7aaab2d886a7642e79e91f27a533d3b4cad4f6d
sha256sums = b0e621a39e0a050ce119fb4bea888afc7a02039ee9f37a2a5b518e4fe924b3f1
-pkgname = gzdoom-git
+pkgname = gzdoom
diff --git a/PKGBUILD b/PKGBUILD
index f2dda51700ee..edfa31be2000 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,11 @@
# Maintainer: Jan Cholasta <grubber at grubber cz>
+# Contributor: Christoph Zeiler <rabyte*gmail>
_name=gzdoom
-pkgname=${_name}-git
-pkgver=3.6pre+20+ga10f9526b
+pkgname=${_name}
+pkgver=3.5.0
pkgrel=1
-pkgdesc='Advanced Doom source port with OpenGL support (git version)'
+pkgdesc='Advanced Doom source port with OpenGL support'
arch=('i686' 'x86_64')
url='http://www.zdoom.org/'
license=('BSD' 'custom:dumb' 'GPL3' 'LGPL3')
@@ -40,22 +41,14 @@ optdepends=('blasphemer-wad: Blasphemer (free Heretic) game data'
'square1-wad: The Adventures of Square, Episode 1 game data'
'urbanbrawl-wad: Urban Brawl: Action Doom 2 game data'
'xorg-xmessage: crash dialog (other)')
-provides=("${_name}")
-conflicts=("${_name}")
-replaces=("${_name}1-git")
-source=("${_name}::git://github.com/coelckers/${_name}.git"
+replaces=("${_name}1")
+source=("${_name}::git://github.com/coelckers/${_name}.git#tag=g${pkgver}"
"${_name}.desktop"
'0001-Fix-soundfont-search-path.patch')
sha256sums=('SKIP'
'59122e670f72aa2531aff370e7aaab2d886a7642e79e91f27a533d3b4cad4f6d'
'b0e621a39e0a050ce119fb4bea888afc7a02039ee9f37a2a5b518e4fe924b3f1')
-pkgver() {
- cd $_name
-
- git describe --tags --match '[Gg]*' | sed -r 's/^[Gg]//;s/-/+/g'
-}
-
prepare() {
cd $_name