summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--0001-Fix-soundfont-search-path.patch20
-rw-r--r--PKGBUILD8
3 files changed, 21 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9b9f551c979b..137c611bc5ea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gzdoom
pkgdesc = Advanced Doom source port with OpenGL support
- pkgver = 3.5.1
+ pkgver = 3.6.0
pkgrel = 1
url = http://www.zdoom.org/
arch = i686
@@ -42,12 +42,12 @@ pkgbase = gzdoom
optdepends = urbanbrawl-wad: Urban Brawl: Action Doom 2 game data
optdepends = xorg-xmessage: crash dialog (other)
replaces = gzdoom1
- source = gzdoom::git://github.com/coelckers/gzdoom.git#tag=g3.5.1
+ source = gzdoom::git://github.com/coelckers/gzdoom.git#tag=g3.6.0
source = gzdoom.desktop
source = 0001-Fix-soundfont-search-path.patch
sha256sums = SKIP
sha256sums = 59122e670f72aa2531aff370e7aaab2d886a7642e79e91f27a533d3b4cad4f6d
- sha256sums = b0e621a39e0a050ce119fb4bea888afc7a02039ee9f37a2a5b518e4fe924b3f1
+ sha256sums = 11323f98caadb086b35cce1697744eeba53c96a3f4f9a8c9184ed23e6fb1ea61
pkgname = gzdoom
diff --git a/0001-Fix-soundfont-search-path.patch b/0001-Fix-soundfont-search-path.patch
index 4209ab9f26fe..0c1ac9da73fd 100644
--- a/0001-Fix-soundfont-search-path.patch
+++ b/0001-Fix-soundfont-search-path.patch
@@ -1,29 +1,33 @@
-From 6147e4496a26f0571a2918bbc82b4b1483df8545 Mon Sep 17 00:00:00 2001
+From c70f3a7973eef99c6709f11be75d7fe1bdc29efd Mon Sep 17 00:00:00 2001
From: Jan Cholasta <jan@cholasta.net>
Date: Mon, 5 Mar 2018 16:17:24 +0100
Subject: [PATCH] Fix soundfont search path
---
- src/gameconfigfile.cpp | 2 ++
- 1 file changed, 2 insertions(+)
+ src/gameconfigfile.cpp | 3 +++
+ 1 file changed, 3 insertions(+)
diff --git a/src/gameconfigfile.cpp b/src/gameconfigfile.cpp
-index cb47c3597..452fd4160 100644
+index 2979420f9..c8f22895c 100644
--- a/src/gameconfigfile.cpp
+++ b/src/gameconfigfile.cpp
-@@ -143,10 +143,12 @@ FGameConfigFile::FGameConfigFile ()
- SetValueForKey("Path", "$PROGDIR/soundfonts", true);
+@@ -149,6 +149,8 @@ FGameConfigFile::FGameConfigFile ()
#else
SetValueForKey("Path", "$HOME/" GAME_DIR "/soundfonts", true);
+ SetValueForKey("Path", "$HOME/" GAME_DIR "/fm_banks", true);
+ SetValueForKey("Path", SHARE_DIR "/soundfonts", true);
++ SetValueForKey("Path", SHARE_DIR "/fm_banks", true);
SetValueForKey("Path", "/usr/local/share/doom/soundfonts", true);
+ SetValueForKey("Path", "/usr/local/share/doom/fm_banks", true);
SetValueForKey("Path", "/usr/local/share/games/doom/soundfonts", true);
- SetValueForKey("Path", "/usr/share/doom/soundfonts", true);
+@@ -157,6 +159,7 @@ FGameConfigFile::FGameConfigFile ()
+ SetValueForKey("Path", "/usr/share/doom/fm_banks", true);
SetValueForKey("Path", "/usr/share/games/doom/soundfonts", true);
+ SetValueForKey("Path", "/usr/share/games/doom/fm_banks", true);
+ SetValueForKey("Path", "/usr/share/soundfonts", true);
#endif
}
--
-2.18.0
+2.19.0
diff --git a/PKGBUILD b/PKGBUILD
index a824b76cf9fe..f10c380e55e7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_name=gzdoom
pkgname=${_name}
-pkgver=3.5.1
+pkgver=3.6.0
pkgrel=1
pkgdesc='Advanced Doom source port with OpenGL support'
arch=('i686' 'x86_64')
@@ -47,7 +47,7 @@ source=("${_name}::git://github.com/coelckers/${_name}.git#tag=g${pkgver}"
'0001-Fix-soundfont-search-path.patch')
sha256sums=('SKIP'
'59122e670f72aa2531aff370e7aaab2d886a7642e79e91f27a533d3b4cad4f6d'
- 'b0e621a39e0a050ce119fb4bea888afc7a02039ee9f37a2a5b518e4fe924b3f1')
+ '11323f98caadb086b35cce1697744eeba53c96a3f4f9a8c9184ed23e6fb1ea61')
prepare() {
cd $_name
@@ -75,6 +75,10 @@ package() {
make install DESTDIR="$pkgdir"
install -D -m644 soundfonts/gzdoom.sf2 \
"$pkgdir"/usr/share/$_name/soundfonts/gzdoom.sf2
+ install -D -m644 fm_banks/GENMIDI.GS.wopl \
+ "$pkgdir"/usr/share/$_name/fm_banks/GENMIDI.GS.wopl
+ install -D -m644 fm_banks/gs-by-papiezak-and-sneakernets.wopn \
+ "$pkgdir"/usr/share/$_name/fm_banks/gs-by-papiezak-and-sneakernets.wopn
desktop-file-install --dir="$pkgdir"/usr/share/applications \
"$srcdir"/${_name}.desktop