summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--0001-Fix-path-to-FluidR3-soundfont.patch25
-rw-r--r--0001-Fix-soundfont-search-path.patch29
-rw-r--r--0002-Added-SHARE_DIR-search-path-back.patch25
-rw-r--r--PKGBUILD17
5 files changed, 41 insertions, 68 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 02bf55d45a2b..b923b3b5c11e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gzdoom
pkgdesc = Advanced Doom source port with OpenGL support
- pkgver = 3.2.5
- pkgrel = 3
+ pkgver = 3.3.0
+ pkgrel = 1
url = http://www.zdoom.org/
arch = i686
arch = x86_64
@@ -39,18 +39,15 @@ pkgbase = gzdoom
optdepends = soundfont-fluid: FluidR3 soundfont for FluidSynth
optdepends = strife0-wad: Strife shareware game data
optdepends = square1-wad: The Adventures of Square, Episode 1 game data
- optdepends = timidity++: Timidity MIDI device
optdepends = urbanbrawl-wad: Urban Brawl: Action Doom 2 game data
optdepends = xorg-xmessage: crash dialog (other)
replaces = gzdoom1
- source = gzdoom::git://github.com/coelckers/gzdoom.git#tag=g3.2.5
+ source = gzdoom::git://github.com/coelckers/gzdoom.git#tag=g3.3.0
source = gzdoom.desktop
- source = 0001-Fix-path-to-FluidR3-soundfont.patch
- source = 0002-Added-SHARE_DIR-search-path-back.patch
+ source = 0001-Fix-soundfont-search-path.patch
sha256sums = SKIP
sha256sums = 59122e670f72aa2531aff370e7aaab2d886a7642e79e91f27a533d3b4cad4f6d
- sha256sums = 94834c91230c5c3743d47fc83b7d143d827e11e10b528a7d4f2b96e577c1123d
- sha256sums = 0f7401c77b615f5ce5484da2d65776ee7c989b0160953778adfceb3c631d29dd
+ sha256sums = aece1a10e7da53acf8f51387b922f6a0f5b2bb693255ad95a84a169460bacf43
pkgname = gzdoom
diff --git a/0001-Fix-path-to-FluidR3-soundfont.patch b/0001-Fix-path-to-FluidR3-soundfont.patch
deleted file mode 100644
index 309efc880f9f..000000000000
--- a/0001-Fix-path-to-FluidR3-soundfont.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From a5061668fe18fa8b234cd09780a41f7542169b99 Mon Sep 17 00:00:00 2001
-From: Jan Cholasta <jan@cholasta.net>
-Date: Sun, 17 Sep 2017 10:45:32 +0200
-Subject: [PATCH] Fix path to FluidR3 soundfont
-
----
- src/sound/mididevices/music_fluidsynth_mididevice.cpp | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/sound/mididevices/music_fluidsynth_mididevice.cpp b/src/sound/mididevices/music_fluidsynth_mididevice.cpp
-index 07102c43d..c32a17d8b 100644
---- a/src/sound/mididevices/music_fluidsynth_mididevice.cpp
-+++ b/src/sound/mididevices/music_fluidsynth_mididevice.cpp
-@@ -327,7 +327,7 @@ FluidSynthMIDIDevice::FluidSynthMIDIDevice(const char *args)
- }
- #ifdef __unix__
- // This is the standard location on Ubuntu.
-- if (LoadPatchSets("/usr/share/sounds/sf2/FluidR3_GS.sf2:/usr/share/sounds/sf2/FluidR3_GM.sf2"))
-+ if (LoadPatchSets("/usr/share/soundfonts/FluidR3_GS.sf2:/usr/share/soundfonts/FluidR3_GM.sf2"))
- {
- return;
- }
---
-2.14.2
-
diff --git a/0001-Fix-soundfont-search-path.patch b/0001-Fix-soundfont-search-path.patch
new file mode 100644
index 000000000000..ac07ae3ac560
--- /dev/null
+++ b/0001-Fix-soundfont-search-path.patch
@@ -0,0 +1,29 @@
+From 7b0025cbc85f62086be6852c616e11bb2c94f205 Mon Sep 17 00:00:00 2001
+From: Jan Cholasta <jan@cholasta.net>
+Date: Mon, 5 Mar 2018 16:17:24 +0100
+Subject: [PATCH] Fix soundfont search path
+
+---
+ src/gameconfigfile.cpp | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/src/gameconfigfile.cpp b/src/gameconfigfile.cpp
+index c2655c359..caa221cfe 100644
+--- a/src/gameconfigfile.cpp
++++ b/src/gameconfigfile.cpp
+@@ -181,10 +181,12 @@ FGameConfigFile::FGameConfigFile ()
+ SetValueForKey("Path", "$PROGDIR/soundfonts", true);
+ #else
+ SetValueForKey("Path", "$HOME/" GAME_DIR "/soundfonts", true);
++ SetValueForKey("Path", SHARE_DIR "/soundfonts", true);
+ SetValueForKey("Path", "/usr/local/share/doom/soundfonts", true);
+ SetValueForKey("Path", "/usr/local/share/games/doom/soundfonts", true);
+ SetValueForKey("Path", "/usr/share/doom/soundfonts", true);
+ SetValueForKey("Path", "/usr/share/games/doom/soundfonts", true);
++ SetValueForKey("Path", "/usr/share/soundfonts", true);
+ #endif
+ }
+
+--
+2.16.2
+
diff --git a/0002-Added-SHARE_DIR-search-path-back.patch b/0002-Added-SHARE_DIR-search-path-back.patch
deleted file mode 100644
index e30f08c02f98..000000000000
--- a/0002-Added-SHARE_DIR-search-path-back.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From 2b9a2b11ba49f9033565d9a6d9b508f5ef7a9cc1 Mon Sep 17 00:00:00 2001
-From: "alexey.lysiuk" <alexey.lysiuk@gmail.com>
-Date: Sat, 24 Feb 2018 17:50:13 +0200
-Subject: [PATCH] Added SHARE_DIR search path back
-
-https://github.com/coelckers/gzdoom/pull/377#issuecomment-368235506
----
- src/gameconfigfile.cpp | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/src/gameconfigfile.cpp b/src/gameconfigfile.cpp
-index f6fc12dfa..6e731d2bc 100644
---- a/src/gameconfigfile.cpp
-+++ b/src/gameconfigfile.cpp
-@@ -149,6 +149,7 @@ FGameConfigFile::FGameConfigFile ()
- SetValueForKey ("Path", "$PROGDIR", true);
- #else
- SetValueForKey ("Path", "~/" GAME_DIR, true);
-+ SetValueForKey ("Path", SHARE_DIR, true);
- SetValueForKey ("Path", "/usr/local/share/doom", true);
- SetValueForKey ("Path", "/usr/local/share/games/doom", true);
- SetValueForKey ("Path", "/usr/share/doom", true);
---
-2.16.2
-
diff --git a/PKGBUILD b/PKGBUILD
index 6682c518f403..2c56cbe6a605 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
_name=gzdoom
pkgname=${_name}
-pkgver=3.2.5
-pkgrel=3
+pkgver=3.3.0
+pkgrel=1
pkgdesc='Advanced Doom source port with OpenGL support'
arch=('i686' 'x86_64')
url='http://www.zdoom.org/'
@@ -39,24 +39,20 @@ optdepends=('blasphemer-wad: Blasphemer (free Heretic) game data'
'soundfont-fluid: FluidR3 soundfont for FluidSynth'
'strife0-wad: Strife shareware game data'
'square1-wad: The Adventures of Square, Episode 1 game data'
- 'timidity++: Timidity MIDI device'
'urbanbrawl-wad: Urban Brawl: Action Doom 2 game data'
'xorg-xmessage: crash dialog (other)')
replaces=("${_name}1")
source=("${_name}::git://github.com/coelckers/${_name}.git#tag=g${pkgver}"
"${_name}.desktop"
- '0001-Fix-path-to-FluidR3-soundfont.patch'
- '0002-Added-SHARE_DIR-search-path-back.patch')
+ '0001-Fix-soundfont-search-path.patch')
sha256sums=('SKIP'
'59122e670f72aa2531aff370e7aaab2d886a7642e79e91f27a533d3b4cad4f6d'
- '94834c91230c5c3743d47fc83b7d143d827e11e10b528a7d4f2b96e577c1123d'
- '0f7401c77b615f5ce5484da2d65776ee7c989b0160953778adfceb3c631d29dd')
+ 'aece1a10e7da53acf8f51387b922f6a0f5b2bb693255ad95a84a169460bacf43')
prepare() {
cd $_name
- patch -p1 -i"$srcdir"/0001-Fix-path-to-FluidR3-soundfont.patch
- patch -p1 -i"$srcdir"/0002-Added-SHARE_DIR-search-path-back.patch
+ patch -p1 -i"$srcdir"/0001-Fix-soundfont-search-path.patch
}
build() {
@@ -77,7 +73,8 @@ package() {
cd $_name
make install DESTDIR="$pkgdir"
- install -D -m644 ${_name}.sf2 "$pkgdir"/usr/share/$_name
+ install -D -m644 soundfonts/gzdoom.sf2 \
+ "$pkgdir"/usr/share/$_name/soundfonts/gzdoom.sf2
desktop-file-install --dir="$pkgdir"/usr/share/applications \
"$srcdir"/${_name}.desktop