summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD47
-rw-r--r--h2o.service14
3 files changed, 86 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8a9f51c2804a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = h2o
+ pkgdesc = Optimized HTTP server with support for HTTP/1.x and HTTP/2
+ pkgver = 1.2.0
+ pkgrel = 2
+ url = https://github.com/h2o/h2o
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = cmake
+ makedepends = make
+ depends = libuv
+ depends = libyaml
+ depends = openssl
+ depends = wslay
+ provides = h2o
+ provides = libh2o
+ conflicts = libh2o
+ backup = etc/h2o.conf
+ source = h2o-1.2.0.tar.gz::https://codeload.github.com/h2o/h2o/tar.gz/v1.2.0
+ source = h2o.service
+ sha256sums = 09aacd84ea0a53eaffdc8e0c2a2cf1108bea5db81d5859a136221fd67f07833f
+ sha256sums = dadc4d08e8149ac0f9f2156251a639380795d1fed2068958b487da88161d4bb7
+
+pkgname = h2o
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..28cdb1248f4e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
+# Contributor: Paul Préfontaine <paul+archlinuxaur@prefontaine.name>
+
+pkgname=h2o
+pkgver=1.2.0
+pkgrel=2
+pkgdesc="Optimized HTTP server with support for HTTP/1.x and HTTP/2"
+arch=('i686' 'x86_64')
+depends=('libuv' 'libyaml' 'openssl' 'wslay')
+makedepends=('cmake' 'make')
+url="https://github.com/h2o/h2o"
+license=('MIT')
+source=($pkgname-$pkgver.tar.gz::https://codeload.github.com/h2o/$pkgname/tar.gz/v$pkgver
+ h2o.service)
+sha256sums=('09aacd84ea0a53eaffdc8e0c2a2cf1108bea5db81d5859a136221fd67f07833f'
+ 'dadc4d08e8149ac0f9f2156251a639380795d1fed2068958b487da88161d4bb7')
+backup=('etc/h2o.conf')
+provides=('h2o' 'libh2o')
+conflicts=('libh2o')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ msg2 'Building...'
+ cmake -DCMAKE_INSTALL_PREFIX=/usr .
+ make
+ make libh2o
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ msg2 'Installing license...'
+ install -Dm 644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+ msg2 'Installing documentation...'
+ install -Dm 644 README.md "$pkgdir/usr/share/doc/$pkgname/README.md"
+
+ msg2 'Installing systemd service...'
+ install -Dm 644 "$srcdir/h2o.service" "$pkgdir/usr/lib/systemd/system/h2o.service"
+
+ msg2 'Installing conf file...'
+ install -Dm 644 examples/h2o/h2o.conf "$pkgdir/etc/h2o.conf"
+
+ msg2 'Installing...'
+ make DESTDIR="$pkgdir" install
+}
diff --git a/h2o.service b/h2o.service
new file mode 100644
index 000000000000..80108332a6af
--- /dev/null
+++ b/h2o.service
@@ -0,0 +1,14 @@
+[Unit]
+Description=h2o, a very fast HTTP server written in C
+After=network.target
+
+[Service]
+Type=simple
+SyslogLevel=notice
+
+ExecStart=/usr/bin/h2o --mode master --conf /etc/h2o.conf
+ExecReload=/usr/bin/kill -HUP $MAINPID
+KillMode=process
+
+[Install]
+WantedBy=multiuser.target