summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
-rw-r--r--h2o.service14
3 files changed, 13 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 67b8e92f1476..a3fea452b6ce 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = h2o
pkgdesc = Optimized HTTP server with support for HTTP/1.x and HTTP/2
pkgver = 1.4.4
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/h2o/h2o
arch = i686
arch = x86_64
@@ -18,7 +18,7 @@ pkgbase = h2o
source = h2o-1.4.4.tar.gz::https://codeload.github.com/h2o/h2o/tar.gz/v1.4.4
source = h2o.service
sha256sums = 0297ca73dba460653c6edb14dab17095f60616baf7c51e45ac9f8a6d54b9ba55
- sha256sums = dadc4d08e8149ac0f9f2156251a639380795d1fed2068958b487da88161d4bb7
+ sha256sums = 63cd9134cdf47ca2b69bb0bf2a4ccd8b4fd3fd5c79e2a791bdec9a8d1691679b
pkgname = h2o
diff --git a/PKGBUILD b/PKGBUILD
index 11ae964bb09f..c37d20e3144f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
# Contributor: Paul Préfontaine <paul+archlinuxaur@prefontaine.name>
+# Contributor: HLHF
pkgname=h2o
pkgver=1.4.4
-pkgrel=1
+pkgrel=2
pkgdesc="Optimized HTTP server with support for HTTP/1.x and HTTP/2"
arch=('i686' 'x86_64')
depends=('libuv' 'libyaml' 'wslay')
@@ -13,7 +14,7 @@ license=('MIT')
source=($pkgname-$pkgver.tar.gz::https://codeload.github.com/h2o/$pkgname/tar.gz/v$pkgver
h2o.service)
sha256sums=('0297ca73dba460653c6edb14dab17095f60616baf7c51e45ac9f8a6d54b9ba55'
- 'dadc4d08e8149ac0f9f2156251a639380795d1fed2068958b487da88161d4bb7')
+ '63cd9134cdf47ca2b69bb0bf2a4ccd8b4fd3fd5c79e2a791bdec9a8d1691679b')
backup=('etc/h2o.conf')
provides=('h2o' 'libh2o')
conflicts=('libh2o')
diff --git a/h2o.service b/h2o.service
index 80108332a6af..5b5e71688345 100644
--- a/h2o.service
+++ b/h2o.service
@@ -1,14 +1,16 @@
[Unit]
-Description=h2o, a very fast HTTP server written in C
-After=network.target
+Description=H2O - the optimized HTTP/1, HTTP/2 server
+After=network.target nss-lookup.target remote-fs.target
[Service]
Type=simple
-SyslogLevel=notice
-
+PIDFile=/run/h2o.pid
ExecStart=/usr/bin/h2o --mode master --conf /etc/h2o.conf
ExecReload=/usr/bin/kill -HUP $MAINPID
-KillMode=process
+ExecStop=/usr/bin/kill -TERM $MAINPID
+SyslogLevel=notice
+PrivateTmp=true
+LimitNOFILE=infinity
[Install]
-WantedBy=multiuser.target
+WantedBy=multi-user.target