summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD36
-rw-r--r--h5pyViewer.desktop10
3 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c4241a11c179
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = h5pyviewer
+ pkgdesc = Classes and tools to view *.hdf5-Files
+ pkgver = 0.0.1.6
+ pkgrel = 1
+ url = https://github.com/ganymede42/h5pyViewer
+ arch = any
+ license = BSD
+ depends = python2
+ depends = python2-h5py
+ depends = python2-numpy
+ depends = python2-matplotlib
+ depends = wxpython
+ source = https://files.pythonhosted.org/packages/source/h/h5pyViewer/h5pyViewer-0.0.1.6.tar.gz
+ source = h5pyViewer.desktop
+ md5sums = da47fcfe8e05764abae49a174b6c8621
+ md5sums = 3be07481951e4a264ae9af04b001616c
+
+pkgname = h5pyviewer
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d9e2c280fb36
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+_name=h5pyViewer
+pkgname=h5pyviewer
+pkgver=0.0.1.6
+pkgrel=1
+pkgdesc='Classes and tools to view *.hdf5-Files'
+url="https://github.com/ganymede42/$_name"
+depends=('python2' 'python2-h5py' 'python2-numpy' 'python2-matplotlib' 'wxpython')
+license=('BSD')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz" "$_name.desktop")
+md5sums=('da47fcfe8e05764abae49a174b6c8621'
+ '3be07481951e4a264ae9af04b001616c')
+
+build() {
+ cd "$srcdir/$_name-$pkgver"
+
+ python2 setup.py build
+
+ sed -i 's:#!/usr/bin/env python:#!/usr/bin/env python2:' $_name/*.py
+}
+
+
+package() {
+ cd "$srcdir/$_name-$pkgver"
+
+ install -d "$pkgdir/usr/bin"
+ python2 setup.py install --root="$pkgdir" --optimize=1
+
+ install -Dm755 "$srcdir/$_name.desktop" "$pkgdir/usr/share/applications/$_name.desktop"
+
+ for link in "$pkgdir/usr/bin/"*; do
+ local abs_target="$(readlink "$link")"
+ local rel_target="$(realpath --relative-to="$pkgdir" "$abs_target")"
+ ln -sfT "/$rel_target" "$link"
+ done
+}
diff --git a/h5pyViewer.desktop b/h5pyViewer.desktop
new file mode 100644
index 000000000000..2e990ae0a1c6
--- /dev/null
+++ b/h5pyViewer.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=h5pyViewer
+GenericName=HDF5 File Viewer
+Comment=Classes and tools to view *.hdf5-Files
+Exec=h5pyViewer
+Icon=view-list-tree
+StartupNotify=true
+Terminal=false
+Type=Application
+Categories=Science;