summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD27
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2a679d708ea9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = hackgregator
+ pkgdesc = This application is a comfortable reader application for news.ycombinator.com
+ pkgver = 0.3.0
+ pkgrel = 1
+ url = https://gitlab.com/gunibert/hackgregator
+ arch = x86_64
+ license = GPL3
+ checkdepends = appstream-glib
+ makedepends = git
+ makedepends = gobject-introspection
+ makedepends = meson
+ makedepends = ninja
+ depends = glib2
+ depends = gtk3
+ depends = libhandy
+ depends = libsoup
+ depends = json-glib
+ depends = webkit2gtk
+ source = https://gitlab.com/gunibert/hackgregator/-/archive/0.3.0/hackgregator-0.3.0.tar.gz
+ sha256sums = 577a9f0d2185d67c14e2fd26a7ecec15a4512b693253198c68a31c132f621426
+
+pkgname = hackgregator
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eeae00bee38d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Igor Dyatlov <dyatlov.igor@protonmail.com>
+
+pkgname=hackgregator
+pkgver=0.3.0
+pkgrel=1
+pkgdesc="This application is a comfortable reader application for news.ycombinator.com"
+arch=('x86_64')
+url="https://gitlab.com/gunibert/hackgregator"
+license=('GPL3')
+depends=('glib2' 'gtk3' 'libhandy' 'libsoup' 'json-glib' 'webkit2gtk')
+makedepends=('git' 'gobject-introspection' 'meson' 'ninja')
+checkdepends=('appstream-glib')
+source=($url/-/archive/$pkgver/$pkgname-$pkgver.tar.gz)
+sha256sums=('577a9f0d2185d67c14e2fd26a7ecec15a4512b693253198c68a31c132f621426')
+
+build() {
+ arch-meson $pkgname-$pkgver build
+ meson compile -C build
+}
+
+check() {
+ meson test -C build --print-errorlogs
+}
+
+package() {
+ DESTDIR="${pkgdir}" meson install -C build
+}