summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD14
2 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 82770045610d..0a06a7cefbe3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = handlr-bin
pkgdesc = Powerful alternative to xdg-utils written in Rust
pkgver = 0.6.4
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/chmln/handlr
arch = x86_64
license = MIT
- source = https://github.com/chmln/handlr/releases/download/v0.6.4/handlr
- source = https://github.com/chmln/handlr/raw/v0.6.4/completions/handlr.fish
- source = https://github.com/chmln/handlr/raw/v0.6.4/completions/_handlr
+ source = handlr-0.6.4::https://github.com/chmln/handlr/releases/download/v0.6.4/handlr
+ source = handlr-0.6.4.fish::https://github.com/chmln/handlr/raw/v0.6.4/completions/handlr.fish
+ source = _handlr-0.6.4::https://github.com/chmln/handlr/raw/v0.6.4/completions/_handlr
sha256sums = 287e119d75d8bbdb3416f2b3a0962f2625cd4eec946c67305af2069da31ffc91
sha256sums = 842e16f29d868a5e6fbb382606c3637d1276eb88e796c775a8ae87b7823bc654
sha256sums = 38a9d67b6b40c1ea1b3f4dc6a650c61330d4c3a4b69182fd1dd16e015f4a1fd6
diff --git a/PKGBUILD b/PKGBUILD
index c4c804d24324..13f5444de772 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,20 +3,20 @@
pkgname=handlr-bin
pkgver=0.6.4
-pkgrel=2
+pkgrel=3
pkgdesc="Powerful alternative to xdg-utils written in Rust"
arch=("x86_64")
url="https://github.com/chmln/handlr"
license=("MIT")
-source=("${url}/releases/download/v${pkgver}/handlr"
- "${url}/raw/v${pkgver}/completions/handlr.fish"
- "${url}/raw/v${pkgver}/completions/_handlr")
+source=("handlr-${pkgver}::${url}/releases/download/v${pkgver}/handlr"
+ "handlr-${pkgver}.fish::${url}/raw/v${pkgver}/completions/handlr.fish"
+ "_handlr-${pkgver}::${url}/raw/v${pkgver}/completions/_handlr")
sha256sums=('287e119d75d8bbdb3416f2b3a0962f2625cd4eec946c67305af2069da31ffc91'
'842e16f29d868a5e6fbb382606c3637d1276eb88e796c775a8ae87b7823bc654'
'38a9d67b6b40c1ea1b3f4dc6a650c61330d4c3a4b69182fd1dd16e015f4a1fd6')
package() {
- install -Dm 755 handlr "${pkgdir}/usr/bin/handlr"
- install -Dm 755 handlr.fish "${pkgdir}/usr/share/fish/vendor_completions.d/handlr.fish"
- install -Dm 755 _handlr "${pkgdir}/usr/share/zsh/site-functions/_handlr"
+ install -Dm 755 "handlr-${pkgver}" "${pkgdir}/usr/bin/handlr"
+ install -Dm 755 "handlr-${pkgver}.fish" "${pkgdir}/usr/share/fish/vendor_completions.d/handlr.fish"
+ install -Dm 755 "_handlr-${pkgver}" "${pkgdir}/usr/share/zsh/site-functions/_handlr"
}