summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD23
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4e40f4e30841
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Thu Mar 24 17:58:04 UTC 2016
+pkgbase = haraka
+ pkgdesc = A node.js mail server
+ pkgver = 2.8.0_alpha.7
+ pkgrel = 1
+ url = http://haraka.github.io/
+ arch = any
+ license = MIT
+ depends = nodejs
+ depends = npm
+ noextract = Haraka-2.8.0-alpha.7.tgz
+ source = http://registry.npmjs.org/Haraka/-/Haraka-2.8.0-alpha.7.tgz
+ sha1sums = c8e874e7b77a1048f4afd57f9463b4cf717a0d92
+
+pkgname = haraka
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6b8b74da43ab
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: juantascon
+
+_npmname=Haraka
+_npmver=2.8.0-alpha.7
+pkgname=haraka
+pkgver=2.8.0_alpha.7
+pkgrel=1
+pkgdesc="A node.js mail server"
+arch=(any)
+url="http://haraka.github.io/"
+license=("MIT")
+depends=('nodejs' 'npm')
+source=(http://registry.npmjs.org/$_npmname/-/$_npmname-$_npmver.tgz)
+noextract=($_npmname-$_npmver.tgz)
+sha1sums=('c8e874e7b77a1048f4afd57f9463b4cf717a0d92')
+
+package() {
+ cd "$srcdir"
+ local _npmdir="$pkgdir/usr/lib/node_modules/"
+ mkdir -p "$_npmdir"
+ cd "$_npmdir"
+ npm install -g --prefix "$pkgdir/usr" $_npmname@$_npmver
+}