summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO31
-rw-r--r--Harmony.desktop8
-rw-r--r--PKGBUILD47
-rwxr-xr-xharmony2
-rw-r--r--harmony-16.pngbin0 -> 1502 bytes
-rw-r--r--harmony-256.pngbin0 -> 50983 bytes
-rw-r--r--harmony-32.pngbin0 -> 2855 bytes
7 files changed, 88 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..585b393d7229
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = harmony-player
+ pkgdesc = A next-gen music player built with Electron.
+ pkgver = 0.2.4
+ pkgrel = 1
+ url = http://getharmony.xyz/
+ arch = x86_64
+ license = GPL
+ depends = gnuplot
+ depends = python
+ depends = gconf
+ depends = libxss
+ depends = libxtst
+ depends = nodejs
+ depends = alsa-lib
+ depends = nss
+ depends = gtk2
+ source = harmony-0.2.4.tar.xz::https://github.com/vincelwt/harmony/releases/download/0.2.4/harmony-0.2.4.tar.xz
+ source = Harmony.desktop
+ source = harmony-16.png
+ source = harmony-32.png
+ source = harmony-256.png
+ source = harmony
+ md5sums = 347768ee9cd27786e52a9a03391adcc6
+ md5sums = 1a635e04543694457179313e4ca7b315
+ md5sums = 9ff4e602debeaf6d88c625189342db52
+ md5sums = d3ff15f6c1dd18a81a933242aae9c892
+ md5sums = 0df74ddd513dbea8d1fb130c4232bd73
+ md5sums = 8340d5f3171e1846082e93bb0269e115
+
+pkgname = harmony-player
+
diff --git a/Harmony.desktop b/Harmony.desktop
new file mode 100644
index 000000000000..55b5c77b6691
--- /dev/null
+++ b/Harmony.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=Harmony
+Comment=Listen to music from Spotify, SoundCloud, Google Play Music or your local disk,
+Exec="/opt/Harmony/Harmony"
+Terminal=false
+Type=Application
+Icon=harmony
+Categories=Music;Audio;AudioVideo
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..55251c69c38c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Gustav Hansen <kusti8@gmail.com>
+pkgname=harmony-player
+pkgver=0.2.4
+pkgrel=1
+pkgdesc="A next-gen music player built with Electron."
+arch=('x86_64')
+url="http://getharmony.xyz/"
+license=('GPL')
+groups=()
+depends=('gnuplot' 'python' 'gconf' 'libxss' 'libxtst' 'nodejs' 'alsa-lib' 'nss' 'gtk2')
+makedepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+source=("harmony-$pkgver.tar.xz::https://github.com/vincelwt/harmony/releases/download/$pkgver/harmony-$pkgver.tar.xz"
+ "Harmony.desktop"
+ "harmony-16.png"
+ "harmony-32.png"
+ "harmony-256.png"
+ "harmony")
+md5sums=('347768ee9cd27786e52a9a03391adcc6'
+ '1a635e04543694457179313e4ca7b315'
+ '9ff4e602debeaf6d88c625189342db52'
+ 'd3ff15f6c1dd18a81a933242aae9c892'
+ '0df74ddd513dbea8d1fb130c4232bd73'
+ '8340d5f3171e1846082e93bb0269e115') #autofill using updpkgsums
+
+package() {
+ cd "harmony-$pkgver"
+
+ mkdir -p "$pkgdir/opt/Harmony"
+ mkdir -p "$pkgdir/usr/bin"
+ mkdir -p "$pkgdir/usr/share/applications"
+ mkdir -p "$pkgdir/usr/share/icons/hicolor/16x16/apps"
+ mkdir -p "$pkgdir/usr/share/icons/hicolor/32x32/apps"
+ mkdir -p "$pkgdir/usr/share/icons/hicolor/256x256/apps"
+ cp -r * "$pkgdir/opt/Harmony/"
+
+ cp "$srcdir/harmony" "$pkgdir/usr/bin/Harmony"
+ cp "$srcdir/Harmony.desktop" "$pkgdir/usr/share/applications/"
+ cp "$srcdir/harmony-16.png" "$pkgdir/usr/share/icons/hicolor/16x16/apps/"
+ cp "$srcdir/harmony-32.png" "$pkgdir/usr/share/icons/hicolor/32x32/apps/"
+ cp "$srcdir/harmony-256.png" "$pkgdir/usr/share/icons/hicolor/256x256/apps/"
+}
diff --git a/harmony b/harmony
new file mode 100755
index 000000000000..5fe2dc213dff
--- /dev/null
+++ b/harmony
@@ -0,0 +1,2 @@
+#!/bin/sh
+/opt/Harmony/Harmony
diff --git a/harmony-16.png b/harmony-16.png
new file mode 100644
index 000000000000..6c58016d60e8
--- /dev/null
+++ b/harmony-16.png
Binary files differ
diff --git a/harmony-256.png b/harmony-256.png
new file mode 100644
index 000000000000..e42c4639ec28
--- /dev/null
+++ b/harmony-256.png
Binary files differ
diff --git a/harmony-32.png b/harmony-32.png
new file mode 100644
index 000000000000..141aaf443cb3
--- /dev/null
+++ b/harmony-32.png
Binary files differ