summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD18
-rw-r--r--cuda.patch32
3 files changed, 6 insertions, 50 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1980e1a8af52..ea9b6eaa8462 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = hashclash-git
pkgdesc = Project HashClash - MD5 & SHA-1 cryptanalysis
- pkgver = r45.c1159e9
- pkgrel = 3
+ pkgver = r46.d833657
+ pkgrel = 1
url = https://github.com/cr-marcstevens/hashclash
arch = x86_64
license = MIT
@@ -11,9 +11,7 @@ pkgbase = hashclash-git
provides = hashclash
conflicts = hashclash
source = hashclash::git+https://github.com/cr-marcstevens/hashclash
- source = cuda.patch
md5sums = SKIP
- md5sums = e50c821804f404ed10ccecc790382f8f
pkgname = hashclash-git
diff --git a/PKGBUILD b/PKGBUILD
index 769a27f9a6a7..763f8149762f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Bert Peters <bert@bertptrs.nl>
pkgname=hashclash-git
-pkgver=r45.c1159e9
-pkgrel=3
+pkgver=r46.d833657
+pkgrel=1
pkgdesc="Project HashClash - MD5 & SHA-1 cryptanalysis "
arch=(x86_64)
url="https://github.com/cr-marcstevens/hashclash"
@@ -10,18 +10,8 @@ depends=(boost-libs)
makedepends=('git' 'boost')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-source=("${pkgname%-git}::git+https://github.com/cr-marcstevens/hashclash"
- "cuda.patch")
-md5sums=('SKIP'
- 'e50c821804f404ed10ccecc790382f8f')
-
-# Please refer to the 'USING VCS SOURCES' section of the PKGBUILD man page for
-# a description of each element in the source array.
-
-prepare() {
- cd "$srcdir/${pkgname%-git}"
- patch -p1 < "$srcdir/cuda.patch"
-}
+source=("${pkgname%-git}::git+https://github.com/cr-marcstevens/hashclash")
+md5sums=('SKIP')
pkgver() {
cd "$srcdir/${pkgname%-git}"
diff --git a/cuda.patch b/cuda.patch
deleted file mode 100644
index a18d797914a3..000000000000
--- a/cuda.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-diff --git a/m4/ax_cuda.m4 b/m4/ax_cuda.m4
-index f9d9f8e..82646b0 100644
---- a/m4/ax_cuda.m4
-+++ b/m4/ax_cuda.m4
-@@ -88,17 +88,9 @@ then
- # test if nvcc version is >= 2.3
- NVCC_VERSION=`$NVCC --version | grep release | awk 'gsub(/,/, "") {print [$]5}'`
- AC_MSG_RESULT([nvcc version : $NVCC_VERSION])
--
-+
- # test if architecture is 64 bits and NVCC version >= 2.3
- libdir=lib
-- AX_COMPARE_VERSION([$NVCC_VERSION],[gt],[2.2],[
-- if test "x$host_cpu" = xx86_64 ; then
-- libdir=lib64
-- fi
-- if test "x$host_cpu" = xpowerpc64le ; then
-- libdir=lib64
-- fi
-- ])
-
- # set CUDA flags
- if test -n "$cuda_home_path"
-@@ -163,7 +155,7 @@ then
-
- CPPFLAGS=$saved_CPPFLAGS
- LIBS=$saved_LIBS
--fi
-+fi
-
- have_cuda="no"
- if test "$want_cuda" != "no" -a "$have_cuda_headers" = "yes" -a "$have_cuda_libs" = "yes" -a "$have_nvcc" = "yes"