summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD61
2 files changed, 35 insertions, 48 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c0925e79e2c8..2505618ab0e8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,13 @@
-# Generated by mksrcinfo v8
-# Mon Sep 18 13:02:17 UTC 2017
pkgbase = haskell-curl
- pkgdesc = Haskell binding to libcurl
+ pkgdesc = A Haskell binding to the curl library
pkgver = 1.3.8
pkgrel = 1
- url = http://hackage.haskell.org/package/curl
- arch = any
- license = BSD3
- depends = ghc
- depends = haskell-base
- depends = haskell-bytestring
- depends = haskell-containers
- options = strip
- source = https://hackage.haskell.org/package/curl-1.3.8/curl-1.3.8.tar.gz
- sha256sums = 9087c936bfcdb865bad3166baa3f12bf37acf076fa76010e3b5f82a1d485446e
+ url = https://github.com/galoisinc/curl
+ arch = x86_64
+ license = BSD
+ makedepends = ghc
+ depends = ghc-libs
+ source = https://hackage.haskell.org/packages/archive/curl/1.3.8/curl-1.3.8.tar.gz
+ sha512sums = 00012fc9b0a80b0d306f688bfb9cfbde8aa72045e6a139c0d8a0cdd7832b5e86ab06c6ea95803665f4bb8ec4e9af3dbc6e405f100985c2cfbaead8527ba7a382
pkgname = haskell-curl
-
diff --git a/PKGBUILD b/PKGBUILD
index 7fd188469a0b..b862122579e6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,44 +1,37 @@
-# Maintainer: Carsten Feuls <archlinux@carstenfeuls.de>
-# Generated by hkg2arch --> https://github.com/christopherloen/hkg2arch
-
-hkgname=curl
+#Contributor: Carsten Feuls <archlinux@carstenfeuls.de>
+_hkgname=curl
pkgname=haskell-curl
-pkgrel=1
pkgver=1.3.8
-pkgdesc='Haskell binding to libcurl'
-arch=(any)
-url='http://hackage.haskell.org/package/curl'
-license=(BSD3)
-depends=('ghc' 'haskell-base' 'haskell-bytestring' 'haskell-containers')
-options=(strip)
-source=(https://hackage.haskell.org/package/${hkgname}-${pkgver}/${hkgname}-${pkgver}.tar.gz)
-sha256sums=('9087c936bfcdb865bad3166baa3f12bf37acf076fa76010e3b5f82a1d485446e')
-
-prepare() {
- cd ${srcdir}/${hkgname}-${pkgver}
- runhaskell Setup.hs configure -O --enable-shared --enable-executable-dynamic \
- --prefix=/usr --docdir="/usr/share/doc/${pkgname}" \
- --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid \
- -f-no-unicode -f-system-libyaml -f-no-exe -fno-examples
-}
-
+pkgrel=1
+pkgdesc="A Haskell binding to the curl library"
+url="https://github.com/galoisinc/curl"
+license=('BSD')
+arch=('x86_64')
+depends=('ghc-libs')
+makedepends=('ghc')
+source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
+sha512sums=('00012fc9b0a80b0d306f688bfb9cfbde8aa72045e6a139c0d8a0cdd7832b5e86ab06c6ea95803665f4bb8ec4e9af3dbc6e405f100985c2cfbaead8527ba7a382')
build() {
- cd ${srcdir}/${hkgname}-${pkgver}
- runhaskell Setup build
- runhaskell Setup haddock
- runhaskell Setup register --gen-script
+ cd $_hkgname-$pkgver
+
+ runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
+ --prefix=/usr --docdir=/usr/share/doc/$pkgname \
+ --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
+ runhaskell Setup build $MAKEFLAGS
+ runhaskell Setup register --gen-script
runhaskell Setup unregister --gen-script
+ sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
}
package() {
- cd ${srcdir}/${hkgname}-${pkgver}
- install -D -m744 register.sh "${pkgdir}/usr/share/haskell/register/${pkgname}.sh"
- install -D -m744 unregister.sh "${pkgdir}/usr/share/haskell/unregister/${pkgname}.sh"
- install -d -m755 ${pkgdir}/usr/share/doc/ghc/html/libraries
- ln -s /usr/share/doc/${pkgname}/html ${pkgdir}/usr/share/doc/ghc/html/libraries/${hkgname}
- runhaskell Setup copy --destdir=${pkgdir}
- install -D -m644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
- rm -f ${pkgdir}/usr/share/doc/${pkgname}/LICENSE
+ cd $_hkgname-$pkgver
+
+ install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
+ install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
+ runhaskell Setup copy --destdir="$pkgdir"
+ install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE
}
+