summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD19
2 files changed, 34 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9258ca80433f..b7def2c42d22 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = haskell-linear
pkgdesc = Linear Algebra
- pkgver = 1.17.1
+ pkgver = 1.18.1.1
pkgrel = 1
url = http://hackage.haskell.org/package/linear
install = haskell-linear.install
@@ -8,27 +8,36 @@ pkgbase = haskell-linear
arch = x86_64
license = custom:BSD3
depends = ghc
+ depends = haskell-adjunctions>=4.0
depends = haskell-adjunctions<5
- depends = haskell-binary<0.8
- depends = haskell-bytes<1
+ depends = haskell-cereal>=0.4.1.1
depends = haskell-cereal<0.5
- depends = haskell-containers=0.4.0.0
- depends = haskell-deepseq=1.1.0.2
+ depends = haskell-distributive>=0.2.2
depends = haskell-distributive<1
+ depends = haskell-hashable>=1.1
depends = haskell-hashable<1.3
+ depends = haskell-lens>=4.0
depends = haskell-lens<5
+ depends = haskell-reflection>=1.3.2
depends = haskell-reflection<2
- depends = haskell-semigroupoids<5
+ depends = haskell-semigroupoids>=3.0
+ depends = haskell-semigroupoids<6
+ depends = haskell-semigroups>=0.9
depends = haskell-semigroups<1
+ depends = haskell-tagged>=0.4.4
depends = haskell-tagged<1
- depends = haskell-template-haskell
- depends = haskell-transformers=0.2.2.0
+ depends = haskell-template-haskell>=2.7
+ depends = haskell-template-haskell<3.0
+ depends = haskell-transformers-compat>=0.4
depends = haskell-transformers-compat<1
+ depends = haskell-unordered-containers>=0.2.3
depends = haskell-unordered-containers<0.3
+ depends = haskell-vector>=0.10.0
depends = haskell-vector<0.11
+ depends = haskell-void>=0.6
depends = haskell-void<1
options = strip
- source = http://hackage.haskell.org/packages/archive/linear/1.17.1/linear-1.17.1.tar.gz
+ source = http://hackage.haskell.org/packages/archive/linear/1.18.1.1/linear-1.18.1.1.tar.gz
sha512sums = b60dd3d259a7cdbdb912c790a1d6af0ed287feb8bce99dfdd12810667ba47abb80dc4d0d4d0db8a57a334812fc814521016a23734421178b7e1d5dddf090b4b3
pkgname = haskell-linear
diff --git a/PKGBUILD b/PKGBUILD
index b7c1246d0b1b..7d936a9f4e96 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,27 @@
_hkgname=linear
pkgname=haskell-linear
-pkgver=1.17.1
+pkgver=1.18.1.1
pkgrel=1
pkgdesc="Linear Algebra"
url="http://hackage.haskell.org/package/${_hkgname}"
license=('custom:BSD3')
-arch=('i686' 'x86_64')
+arch=('any')
makedepends=()
-depends=('ghc' 'haskell-adjunctions<5' 'haskell-binary<0.8' 'haskell-bytes<1' 'haskell-cereal<0.5' 'haskell-containers=0.4.0.0' 'haskell-deepseq=1.1.0.2' 'haskell-distributive<1' 'haskell-hashable<1.3' 'haskell-lens<5' 'haskell-reflection<2' 'haskell-semigroupoids<5' 'haskell-semigroups<1' 'haskell-tagged<1' 'haskell-template-haskell' 'haskell-transformers=0.2.2.0' 'haskell-transformers-compat<1' 'haskell-unordered-containers<0.3' 'haskell-vector<0.11' 'haskell-void<1')
+depends=('ghc' 'haskell-adjunctions>=4.0' 'haskell-adjunctions<5'
+ 'haskell-cereal>=0.4.1.1' 'haskell-cereal<0.5'
+ 'haskell-distributive>=0.2.2' 'haskell-distributive<1'
+ 'haskell-hashable>=1.1' 'haskell-hashable<1.3'
+ 'haskell-lens>=4.0' 'haskell-lens<5'
+ 'haskell-reflection>=1.3.2' 'haskell-reflection<2'
+ 'haskell-semigroupoids>=3.0' 'haskell-semigroupoids<6'
+ 'haskell-semigroups>=0.9' 'haskell-semigroups<1'
+ 'haskell-tagged>=0.4.4' 'haskell-tagged<1'
+ 'haskell-template-haskell>=2.7' 'haskell-template-haskell<3.0'
+ 'haskell-transformers-compat>=0.4' 'haskell-transformers-compat<1'
+ 'haskell-unordered-containers>=0.2.3' 'haskell-unordered-containers<0.3'
+ 'haskell-vector>=0.10.0' 'haskell-vector<0.11'
+ 'haskell-void>=0.6' 'haskell-void<1')
options=('strip')
source=(http://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz)
install=${pkgname}.install