summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD20
3 files changed, 19 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5bdf46291f42..0de19078dc5e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = haskell-pointfree
pkgdesc = Tool for refactoring expressions into pointfree form
- pkgver = 1.1.1.9
+ pkgver = 1.1.1.11
pkgrel = 1
url = http://hackage.haskell.org/package/pointfree
arch = i686
@@ -12,7 +12,7 @@ pkgbase = haskell-pointfree
depends = ghc-libs
depends = haskell-src-exts
options = strip
- source = http://hackage.haskell.org/packages/archive/pointfree/1.1.1.9/pointfree-1.1.1.9.tar.gz
- md5sums = ef062edda5dd021d95dda7e006bb52c2
+ source = http://hackage.haskell.org/packages/archive/pointfree/1.1.1.11/pointfree-1.1.1.11.tar.gz
+ md5sums = 88eb005b3c15d95a554786e0eac9f9a0
pkgname = haskell-pointfree
diff --git a/.gitignore b/.gitignore
index a32dd58dda4f..2f3b64cfe24a 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,6 @@
/src/
/pkg/
-haskell-pointfree-*.pkg.tar
+/chroot/
+haskell-pointfree-*.log
+haskell-pointfree-*.pkg.tar*
pointfree-*.tar.gz \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 6b14c4115961..2c90e7edee80 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_hkgname=pointfree
pkgname=haskell-pointfree
-pkgver=1.1.1.9
+pkgver=1.1.1.11
pkgrel=1
pkgdesc="Tool for refactoring expressions into pointfree form"
url="http://hackage.haskell.org/package/${_hkgname}"
@@ -11,16 +11,17 @@ license=('custom:OtherLicense')
arch=('i686' 'x86_64')
makedepends=('ghc')
depends=('gmp' 'ghc' 'ghc-libs' 'haskell-src-exts')
+checkdepends=('haskell-hunit' 'haskell-quickcheck')
options=('strip')
-source=(http://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz)
-md5sums=('ef062edda5dd021d95dda7e006bb52c2')
+source=("http://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
+md5sums=('88eb005b3c15d95a554786e0eac9f9a0')
build() {
- cd ${srcdir}/${_hkgname}-${pkgver}
+ cd "${srcdir}/${_hkgname}-${pkgver}" || exit 1
runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
--prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname \
- --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
- --ghc-option='-pie'
+ --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid \
+ --ghc-option='-pie' --enable-tests
runhaskell Setup build -v $MAKEFLAGS
runhaskell Setup register --gen-script
runhaskell Setup unregister --gen-script
@@ -28,8 +29,13 @@ build() {
sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
}
+check() {
+ cd "${srcdir}/${_hkgname}-${pkgver}" || exit 1
+ runhaskell Setup test
+}
+
package() {
- cd ${srcdir}/${_hkgname}-${pkgver}
+ cd "${srcdir}/${_hkgname}-${pkgver}" || exit 1
install -D -m744 register.sh "${pkgdir}/usr/share/haskell/register/${pkgname}.sh"
install -D -m744 unregister.sh "${pkgdir}/usr/share/haskell/unregister/${pkgname}.sh"