summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD45
-rw-r--r--Setup.hs4
4 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1784949d20cc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = haskell-safe-coloured-text
+ pkgdesc = Safely output coloured text
+ pkgver = 0.2.0.1
+ pkgrel = 1
+ url = https://github.com/NorfairKing/safe-coloured-text#readme
+ arch = x86_64
+ license = MIT
+ makedepends = ghc
+ depends = ghc-libs
+ depends = haskell-validity
+ depends = haskell-validity-bytestring
+ depends = haskell-validity-text
+ source = https://hackage.haskell.org/packages/archive/safe-coloured-text/0.2.0.1/safe-coloured-text-0.2.0.1.tar.gz
+ source = Setup.hs
+ sha256sums = b1604a221ee28e672a5b876a9f368ebbd65d56cc93afeb486083857d7c9b1759
+ sha256sums = f2a37c4a254ff8eb780133ca568ae5f4f4dcdee5219982154e6faef749b8327c
+
+pkgname = haskell-safe-coloured-text
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..8ba3a617d3d9
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg/
+/src/
+/*.tar*
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..31550a73ed34
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# This file was generated by https://github.com/berberman/arch-hs, please check it manually.
+
+_hkgname=safe-coloured-text
+pkgname=haskell-safe-coloured-text
+pkgver=0.2.0.1
+pkgrel=1
+pkgdesc="Safely output coloured text"
+url="https://github.com/NorfairKing/safe-coloured-text#readme"
+license=("MIT")
+arch=('x86_64')
+depends=('ghc-libs' 'haskell-validity' 'haskell-validity-bytestring' 'haskell-validity-text')
+makedepends=('ghc')
+source=("https://hackage.haskell.org/packages/archive/$_hkgname/$pkgver/$_hkgname-$pkgver.tar.gz" 'Setup.hs')
+sha256sums=('b1604a221ee28e672a5b876a9f368ebbd65d56cc93afeb486083857d7c9b1759'
+ 'f2a37c4a254ff8eb780133ca568ae5f4f4dcdee5219982154e6faef749b8327c')
+
+prepare() {
+ cp Setup.hs "$_hkgname-$pkgver/"
+}
+
+build() {
+ cd $_hkgname-$pkgver
+
+ runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
+ --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=haskell-safe-coloured-text --enable-tests \
+ --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid \
+ --ghc-option=-optl-Wl\,-z\,relro\,-z\,now \
+ --ghc-option='-pie'
+
+ runhaskell Setup build
+ runhaskell Setup register --gen-script
+ runhaskell Setup unregister --gen-script
+ sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
+ sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
+}
+
+package() {
+ cd $_hkgname-$pkgver
+
+ install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
+ install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
+ runhaskell Setup copy --destdir="$pkgdir"
+ install -D -m644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/
+ rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE
+}
diff --git a/Setup.hs b/Setup.hs
new file mode 100644
index 000000000000..6479cb1c1645
--- /dev/null
+++ b/Setup.hs
@@ -0,0 +1,4 @@
+import Distribution.Simple
+
+main = defaultMain
+