summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
2 files changed, 11 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 21c402e287bf..f828f3e0e113 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = haskell-threadscope
pkgdesc = A graphical viewer for thread profile information generated by the Glasgow Haskell compiler (GHC).
- pkgver = 0.2.11.1
+ pkgver = 0.2.14
pkgrel = 1
url = http://hackage.haskell.org/package/threadscope
arch = x86_64
@@ -15,8 +15,8 @@ pkgbase = haskell-threadscope
depends = haskell-pango
depends = haskell-text
depends = haskell-file-embed
- source = https://hackage.haskell.org/packages/archive/threadscope/0.2.11.1/threadscope-0.2.11.1.tar.gz
- sha512sums = eb09a4d5db700eaf02f8353e25fb9a2b8b6a070a1196fcd7a5418084d16254b7613e3456a2da0e9e3cec25f7676867336fa85e6d3364138667bb58e7b2238cbb
+ depends = haskell-temporary
+ source = https://hackage.haskell.org/packages/archive/threadscope/0.2.14/threadscope-0.2.14.tar.gz
+ sha512sums = 23e87e3454af1ac353132dd1929281303ff5575269059b2a4d74032c8eb26153d176751fabc18550338dba5bea0ab8a39f8644b55194670a16d262b6bf56d437
pkgname = haskell-threadscope
-
diff --git a/PKGBUILD b/PKGBUILD
index 9db90e00e401..739e57af73f5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_hkgname=threadscope
pkgname=haskell-threadscope
-pkgver=0.2.11.1
+pkgver=0.2.14
pkgrel=1
pkgdesc="A graphical viewer for thread profile information generated by the Glasgow Haskell compiler (GHC)."
url="http://hackage.haskell.org/package/${_hkgname}"
@@ -16,16 +16,18 @@ depends=('ghc-libs'
'haskell-mtl'
'haskell-pango'
'haskell-text'
- 'haskell-file-embed')
+ 'haskell-file-embed'
+ 'haskell-temporary')
makedepends=('ghc')
source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
-sha512sums=('eb09a4d5db700eaf02f8353e25fb9a2b8b6a070a1196fcd7a5418084d16254b7613e3456a2da0e9e3cec25f7676867336fa85e6d3364138667bb58e7b2238cbb')
+sha512sums=('23e87e3454af1ac353132dd1929281303ff5575269059b2a4d74032c8eb26153d176751fabc18550338dba5bea0ab8a39f8644b55194670a16d262b6bf56d437')
prepare() {
cd "${srcdir}/${_hkgname}-${pkgver}"
- sed -i 's/gtk >= 0.12 && < 0.15,/gtk,/' threadscope.cabal
- sed -i 's/template-haskell < 2.14,/template-haskell,/' threadscope.cabal
+ sed -i 's/gtk >= 0.12 && < 0.16,/gtk,/' threadscope.cabal
+ sed -i 's/ghc-events >= 0.13 && < 0.16,/ghc-events,/' threadscope.cabal
+ sed -i 's/template-haskell < 2.16,/template-haskell,/' threadscope.cabal
}
build() {