summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD26
2 files changed, 24 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3724a35929a0..c443d5113fe4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,22 @@
pkgbase = haskell-threadscope
pkgdesc = A graphical viewer for thread profile information generated by the Glasgow Haskell compiler (GHC).
- pkgver = 0.2.7
+ pkgver = 0.2.9
pkgrel = 1
url = http://hackage.haskell.org/package/threadscope
- arch = i686
arch = x86_64
license = custom:BSD3
- depends = ghc>=8.0.1
+ makedepends = ghc
+ depends = ghc-libs
depends = haskell-cairo
- depends = haskell-ghc-events>=0.4.2
+ depends = haskell-ghc-events
depends = haskell-glib
- depends = haskell-gtk2>=0.12
+ depends = haskell-gtk2
depends = haskell-mtl
depends = haskell-pango
depends = haskell-text
- source = https://hackage.haskell.org/packages/archive/threadscope/0.2.7/threadscope-0.2.7.tar.gz
- sha256sums = cc5653831252d55b3ba7506ea648e770b2c4489cdf4d78828f07dc24ea7ffdb6
+ depends = haskell-file-embed
+ source = https://hackage.haskell.org/packages/archive/threadscope/0.2.9/threadscope-0.2.9.tar.gz
+ sha512sums = 0369210b93d99a749cf09ed51724cbfa099544108c91638442a10d504fe1a4bbca933432b479475f8b599dcebb148d7896194f32e078564120806b6e4f1e6724
pkgname = haskell-threadscope
diff --git a/PKGBUILD b/PKGBUILD
index 3045534774dc..b3d7afc4b4af 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,29 +2,35 @@
_hkgname=threadscope
pkgname=haskell-threadscope
-pkgver=0.2.7
+pkgver=0.2.9
pkgrel=1
pkgdesc="A graphical viewer for thread profile information generated by the Glasgow Haskell compiler (GHC)."
url="http://hackage.haskell.org/package/${_hkgname}"
+arch=('x86_64')
license=('custom:BSD3')
-arch=('i686' 'x86_64')
-depends=('ghc>=8.0.1'
+depends=('ghc-libs'
'haskell-cairo'
- 'haskell-ghc-events>=0.4.2'
+ 'haskell-ghc-events'
'haskell-glib'
- 'haskell-gtk2>=0.12'
+ 'haskell-gtk2'
'haskell-mtl'
'haskell-pango'
- 'haskell-text')
+ 'haskell-text'
+ 'haskell-file-embed')
+makedepends=('ghc')
source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
-sha256sums=('cc5653831252d55b3ba7506ea648e770b2c4489cdf4d78828f07dc24ea7ffdb6')
+sha512sums=('0369210b93d99a749cf09ed51724cbfa099544108c91638442a10d504fe1a4bbca933432b479475f8b599dcebb148d7896194f32e078564120806b6e4f1e6724')
+
+prepare() {
+ sed -i 's/ghc-events >= 0.5 && < 0.7,/ghc-events >= 0.5,/' ${_hkgname}-${pkgver}/${_hkgname}.cabal
+}
build() {
cd "${srcdir}/${_hkgname}-${pkgver}"
- runhaskell Setup configure -O --enable-library-profiling --enable-shared \
- --prefix=/usr --docdir="/usr/share/doc/${pkgname}" \
- --libsubdir=\$compiler/site-local/\$pkgid
+ runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
+ --prefix=/usr --docdir="/usr/share/doc/${pkgname}" --datasubdir="$pkgname" \
+ --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid
runhaskell Setup build
}