summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD15
-rw-r--r--remove-duplicated-check.patch13
3 files changed, 29 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3ef8119c266f..d2f5a417f6db 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Tue May 3 19:15:36 UTC 2016
+# Tue May 24 20:27:52 UTC 2016
pkgbase = hdctools-git
pkgdesc = Chrome OS Hardware Debug & Control Tools
- pkgver = r599.a364971
+ pkgver = r610.3601f99
pkgrel = 1
url = http://sites.google.com/a/google.com/chromeos-partner/hardware-control-and-debug
arch = i686
@@ -16,8 +16,11 @@ pkgbase = hdctools-git
depends = python2-pexpect
depends = libftdi
depends = python2-numpy
+ depends = ec-devutil-git
source = git+https://chromium.googlesource.com/chromiumos/third_party/hdctools
+ source = remove-duplicated-check.patch
sha1sums = SKIP
+ sha1sums = d28db1b931b8d5b5755d9c58405af8ecd6cf1610
pkgname = hdctools-git
diff --git a/PKGBUILD b/PKGBUILD
index f14b4d3ccc1b..07e271e1ea18 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,18 @@
# Maintainer: Anatol Pomozov <anatol dot pomozov at gmail>
pkgname=hdctools-git
-pkgver=r599.a364971
+pkgver=r610.3601f99
pkgrel=1
pkgdesc='Chrome OS Hardware Debug & Control Tools'
url='http://sites.google.com/a/google.com/chromeos-partner/hardware-control-and-debug'
arch=(i686 x86_64)
-depends=(python2 python2-pyusb python2-pyserial python2-pexpect libftdi python2-numpy)
+depends=(python2 python2-pyusb python2-pyserial python2-pexpect libftdi python2-numpy ec-devutil-git)
makedepends=(tidyhtml python2-setuptools)
license=(BSD)
-source=(git+https://chromium.googlesource.com/chromiumos/third_party/hdctools)
-sha1sums=('SKIP')
+source=(git+https://chromium.googlesource.com/chromiumos/third_party/hdctools
+ remove-duplicated-check.patch)
+sha1sums=('SKIP'
+ 'd28db1b931b8d5b5755d9c58405af8ecd6cf1610')
#TODO:
# - figure out compile problem with CPPFLAG
@@ -21,6 +23,11 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+prepare() {
+ cd hdctools
+ patch -p1 < ../remove-duplicated-check.patch
+}
+
build() {
cd hdctools
diff --git a/remove-duplicated-check.patch b/remove-duplicated-check.patch
new file mode 100644
index 000000000000..427a8b90fdc4
--- /dev/null
+++ b/remove-duplicated-check.patch
@@ -0,0 +1,13 @@
+diff --git a/lib/ftdiuart.c b/lib/ftdiuart.c
+index 7d1054c..0620dd1 100644
+--- a/lib/ftdiuart.c
++++ b/lib/ftdiuart.c
+@@ -359,7 +359,7 @@ static int fuart_wr_rd_locked(struct fuart_context *fuartc) {
+ rd_buf += bytes;
+ bytes_remaining -= bytes;
+ }
+- if ((bytes == -1) && ((errno == EAGAIN) || (errno == EWOULDBLOCK)) &&
++ if ((bytes == -1) && (errno == EAGAIN) &&
+ (retries < 10)) {
+ retries++;
+ goto retry_write;