summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-x.SRCINFO7
-rwxr-xr-xPKGBUILD8
-rw-r--r--headset.sh5
3 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 12733ef59268..14b279f7cc4a 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,11 @@
pkgbase = headset-bin
pkgdesc = An Electron-based music player for the busy ones
pkgver = 4.2.1
- pkgrel = 7
+ pkgrel = 8
url = https://headsetapp.co/
arch = x86_64
license = MIT
- depends = electron14
- depends = hicolor-icon-theme
+ depends = electron14-bin
provides = headset=4.2.1
conflicts = headset
source = headset-4.2.1.deb::https://github.com/headsetapp/headset-electron/releases/download/v4.2.1/headset_4.2.1_amd64.deb
@@ -14,6 +13,6 @@ pkgbase = headset-bin
source = headset.sh
sha256sums = f3582c22aef8b2081ab84ea0f2933acf4e4a4e6b1b7b8f4265af5a450103c0ca
sha256sums = 0fd4183b7556b9f1b93d974969bad60053ab01db10ed2b501d26ed6840766045
- sha256sums = 50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe
+ sha256sums = dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8
pkgname = headset-bin
diff --git a/PKGBUILD b/PKGBUILD
index 90bb90b38159..ecf30fc4095d 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=headset-bin
pkgver=4.2.1
_electronversion=14
-pkgrel=7
+pkgrel=8
pkgdesc="An Electron-based music player for the busy ones"
arch=(x86_64)
url="https://headsetapp.co/"
@@ -13,8 +13,7 @@ license=('MIT')
provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
depends=(
- "electron${_electronversion}"
- 'hicolor-icon-theme'
+ "electron${_electronversion}-bin"
)
source=(
"${pkgname%-bin}-${pkgver}.deb::${_ghurl}/releases/download/v${pkgver}/${pkgname%-bin}_${pkgver}_amd64.deb"
@@ -23,11 +22,12 @@ source=(
)
sha256sums=('f3582c22aef8b2081ab84ea0f2933acf4e4a4e6b1b7b8f4265af5a450103c0ca'
'0fd4183b7556b9f1b93d974969bad60053ab01db10ed2b501d26ed6840766045'
- '50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe')
+ 'dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8')
build() {
sed -e "s|@electronversion@|${_electronversion}|g" \
-e "s|@appname@|${pkgname%-bin}|g" \
-e "s|@runname@|app.asar|g" \
+ -e "s|@options@||g" \
-i "${srcdir}/${pkgname%-bin}.sh"
bsdtar -xf "${srcdir}/data."*
}
diff --git a/headset.sh b/headset.sh
index 86cb3dc6a9bf..7ddcaab8d734 100644
--- a/headset.sh
+++ b/headset.sh
@@ -2,6 +2,7 @@
set -e
_APPDIR="/usr/lib/@appname@"
_RUNNAME="${_APPDIR}/@runname@"
+_OPTIONS="@options@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
@@ -9,7 +10,7 @@ export ELECTRON_FORCE_IS_PACKAGED=true
export NODE_ENV=production
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron@electronversion@ "${_RUNNAME}" "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" "$@" || exit $?
else
- exec electron@electronversion@ "${_RUNNAME}" --no-sandbox "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" --no-sandbox "$@" || exit $?
fi \ No newline at end of file