aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore8
-rw-r--r--LICENSE22
-rw-r--r--PKGBUILD37
-rw-r--r--README.md12
-rw-r--r--heidisql.desktop10
-rw-r--r--heidisql.pngbin0 -> 10134 bytes
-rwxr-xr-xheidisql.sh34
8 files changed, 145 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2786ba17b8f5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = heidisql
+ pkgdesc = A lightweight GUI for managing MySQL and Microsoft SQL databases. Uses Wine. Package repo: https://github.com/WeCodePixels/heidisql-aur
+ pkgver = 9.2
+ pkgrel = 1
+ url = http://www.heidisql.com/
+ arch = any
+ license = GPL
+ makedepends = unzip
+ depends = bash
+ depends = wine
+ noextract = HeidiSQL_9.2_Portable.zip
+ source = http://www.heidisql.com/downloads/releases/HeidiSQL_9.2_Portable.zip
+ source = heidisql.png
+ source = heidisql.desktop
+ source = heidisql.sh
+ md5sums = e023fbe06e49b6c12d8d2d232f234353
+ md5sums = df3673bc694beceb8ed6cfeace6b6c3f
+ md5sums = ea4fc6959a315ef5c2bf8e22c479e22a
+ md5sums = 3cdbca3164df7d3629ffc469d52e53a0
+
+pkgname = heidisql
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..78e799987c46
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+src
+pkg
+*.tar.xz
+*.tar.gz
+*.log
+.psci_modules
+.directory
+HeidiSQL_* \ No newline at end of file
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..7a65de02dd56
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,22 @@
+The MIT License (MIT)
+
+Copyright (c) 2014 WeCodePixels
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ccf276473232
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Liviu Cristian Mirea-Ghiban <contact at liviucmg dot com>
+pkgname=heidisql
+pkgver=9.2
+pkgrel=1
+pkgdesc="A lightweight GUI for managing MySQL and Microsoft SQL databases. Uses Wine. Package repo: https://github.com/WeCodePixels/heidisql-aur"
+arch=(any)
+url="http://www.heidisql.com/"
+license=('GPL')
+depends=(bash wine)
+makedepends=(unzip)
+source=("http://www.heidisql.com/downloads/releases/HeidiSQL_${pkgver}_Portable.zip"
+ "${pkgname}.png"
+ "${pkgname}.desktop"
+ "${pkgname}.sh")
+md5sums=('e023fbe06e49b6c12d8d2d232f234353'
+ 'df3673bc694beceb8ed6cfeace6b6c3f'
+ 'ea4fc6959a315ef5c2bf8e22c479e22a'
+ '3cdbca3164df7d3629ffc469d52e53a0')
+noextract=("HeidiSQL_${pkgver}_Portable.zip")
+
+package() {
+ # Install files from the .zip file
+ install -d -m755 ${pkgdir}/usr/share/$pkgname
+ unzip "$srcdir/HeidiSQL_${pkgver}_Portable.zip" -d "$srcdir/unzipped"
+ cp -ra "$srcdir/unzipped/"* "${pkgdir}/usr/share/${pkgname}"
+ find "${pkgdir}/usr/share/${pkgname}" -type f -exec chmod 644 "{}" \;
+ find "${pkgdir}/usr/share/${pkgname}" -type d -exec chmod 755 "{}" \;
+
+ # Install the startup script
+ install -Dm755 "${srcdir}/${pkgname}.sh" "${pkgdir}/usr/bin/${pkgname}"
+
+ # Install the icon
+ install -Dm644 "${srcdir}/${pkgname}.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+
+ # Install the .desktop
+ install -Dm644 "${srcdir}/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+}
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..97620f8b7d05
--- /dev/null
+++ b/README.md
@@ -0,0 +1,12 @@
+HeidiSQL AUR package
+============
+
+[HeidiSQL](http://www.heidisql.com/) is a useful and reliable tool designed for web developers using the popular MySQL server, Microsoft SQL databases and PostgreSQL.
+
+This an [AUR](https://aur.archlinux.org/) (Arch User Repository) package that wraps HeidiSQL in order for it to be installed on [Arch Linux](https://www.archlinux.org/) distributions. It is published at [https://aur.archlinux.org/packages/heidisql/](https://aur.archlinux.org/packages/heidisql/).
+
+The releases will be tagged using [semantic versioning](http://semver.org/). E.g. for HeidiSQL 8.3.0, we will be using "v8.3.0-1". If we make a second release of this package for the same version of HeidiSQL, then we will be using "v8.3.0-2".
+
+The current AUR package maintainer is [liviucmg](https://github.com/liviucmg) from [WeCodePixels](http://wecodepixels.com).
+
+Any issues or pull requests are warmly welcome. \ No newline at end of file
diff --git a/heidisql.desktop b/heidisql.desktop
new file mode 100644
index 000000000000..dab23e98fd61
--- /dev/null
+++ b/heidisql.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=HeidiSQL
+GenericName=GUI for managing MySQL and Microsoft SQL databases
+Encoding=UTF-8
+Version=1.0
+Type=Application
+Terminal=false
+Icon=heidisql
+Exec=heidisql
+Categories=Development;Database; \ No newline at end of file
diff --git a/heidisql.png b/heidisql.png
new file mode 100644
index 000000000000..f5f15d25051f
--- /dev/null
+++ b/heidisql.png
Binary files differ
diff --git a/heidisql.sh b/heidisql.sh
new file mode 100755
index 000000000000..9979954c5943
--- /dev/null
+++ b/heidisql.sh
@@ -0,0 +1,34 @@
+#!/bin/bash
+
+progName="heidisql"
+progRealPath="/usr/share/$progName"
+if [ -n "$HEIDISQL_HOME" ]; then
+ progHome="$HEIDISQL_HOME"
+else
+ progHome="$HOME/.$progName"
+fi
+progBin="$progName.exe"
+
+# Create folder
+mkdir -p "$progHome" >/dev/null 2>&1
+
+# Create read-only symlinks
+ln -s "$progRealPath/$progBin" "$progHome/$progBin" >/dev/null 2>&1
+ln -s "$progRealPath/readme.txt" "$progHome/readme.txt" >/dev/null 2>&1
+ln -s "$progRealPath/libmysql.dll" "$progHome/libmysql.dll" >/dev/null 2>&1
+
+# Create a blank config file (otherwise HeidiSQL stores its settings in the Windows Registry)
+if [ -n "$XDG_CONFIG_HOME" ]; then
+ mkdir -p "$XDG_CONFIG_HOME/$progName" >/dev/null 2>&1
+ touch "$XDG_CONFIG_HOME/$progName/portable_settings.txt"
+ ln -s "$XDG_CONFIG_HOME/$progName/portable_settings.txt" "$progHome/portable_settings.txt" >/dev/null 2>&1
+else
+ touch "$progHome/portable_settings.txt"
+fi
+
+# If default wineprefix defined - run from it
+if [ -n "$WINEPREFIX" ]; then
+ WINEDEBUG=-all WINEPREFIX="$WINEPREFIX" wine "$progHome/$progBin" "$@"
+else
+ WINEDEBUG=-all wine "$progHome/$progBin" "$@"
+fi \ No newline at end of file