summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD12
2 files changed, 8 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7d470d98106f..0693ec21d611 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = heimdal-git
pkgdesc = Heimdal, an implementation of Kerberos and PKIX
- pkgver = 7.99.r30417.gb19633f9b
+ pkgver = 7.99.1.r30688.gbcbe81696
pkgrel = 1
url = https://www.heimdal.software/
arch = x86_64
@@ -11,9 +11,8 @@ pkgbase = heimdal-git
depends = readline
depends = sqlite
optdepends = libldap
- provides = heimdal=7.99.r30417.gb19633f9b
- source = git+https://github.com/heimdal/heimdal#commit=b19633f9b94fbfff3777a432d02e0bf5405f372b
- validpgpkeys = E65941B71CF3C459A34FA89C45E7572A28CD8CC8
+ provides = heimdal=7.99.1.r30688.gbcbe81696
+ source = git+https://github.com/heimdal/heimdal#commit=bcbe816962f0f19112f5398cc0a770a7cfacf325
sha256sums = SKIP
pkgname = heimdal-git
diff --git a/PKGBUILD b/PKGBUILD
index 00d48708c631..5cd41068fcfb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
pkgname=heimdal-git
pkgdesc="Heimdal, an implementation of Kerberos and PKIX"
-_commit='b19633f9b94fbfff3777a432d02e0bf5405f372b'
-pkgver=7.99.r30417.gb19633f9b
+_commit='bcbe816962f0f19112f5398cc0a770a7cfacf325'
+pkgver=7.99.1.r30688.gbcbe81696
pkgrel=1
url="https://www.heimdal.software/"
arch=(x86_64)
@@ -11,14 +11,12 @@ optdepends=(libldap)
provides=(heimdal=$pkgver)
source=("git+https://github.com/heimdal/heimdal#commit=$_commit")
sha256sums=('SKIP')
-validpgpkeys=('E65941B71CF3C459A34FA89C45E7572A28CD8CC8')
pkgver() {
cd heimdal
- local ver='7.99'
- #local ver=$({ echo 'changequote([,])dnl'
- # echo 'define(AC_INIT,$2)dnl'
- # grep '^AC_INIT(.*)' configure.ac; } | m4)
+ local ver=$({ echo 'changequote([,])dnl'
+ echo 'define(AC_INIT,$2)dnl'
+ grep '^AC_INIT(.*)' configure.ac; } | m4)
local rev=$(git rev-list --count HEAD)
local git=$(git rev-parse --short HEAD)
echo "$ver.r$rev.g$git"