summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD41
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8baf1b1f1551
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = heliocron-git
+ pkgdesc = Execute tasks relative to sunset, sunrise and other solar events.
+ pkgver = 0.4.0.r4.g89ae185
+ pkgrel = 1
+ url = https://github.com/mfreeborn/heliocron
+ arch = x86_64
+ license = Apache
+ license = MIT
+ makedepends = rust
+ provides = heliocron
+ conflicts = heliocron-bin
+ source = git+https://github.com/mfreeborn/heliocron
+ sha256sums = SKIP
+
+pkgname = heliocron-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f0f6c7dd027c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Heliocron
+
+# Maintainer: Andrea Feletto <andrea@andreafeletto.com>
+
+pkgname=heliocron-git
+_pkgname=${pkgname%-*}
+pkgver=0.4.0.r4.g89ae185
+pkgrel=1
+pkgdesc='Execute tasks relative to sunset, sunrise and other solar events.'
+arch=('x86_64')
+url='https://github.com/mfreeborn/heliocron'
+license=('Apache' 'MIT')
+provides=('heliocron')
+conflicts=('heliocron-bin')
+makedepends=('rust')
+source=("git+https://github.com/mfreeborn/$_pkgname")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --long --tags | sed 's/^v//;s/-/.r/;s/-/./'
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+ env CARGO_INCREMENTAL=0 cargo build --release
+}
+
+#
+# currently not all tests are passed, but binary works
+#
+# check() {
+# cd "$srcdir/$_pkgname"
+# env CARGO_INCREMENTAL=0 cargo test --release
+# }
+
+package() {
+ cd "$srcdir/$_pkgname"
+ install -Dm755 "target/release/$_pkgname" "$pkgdir/usr/bin/$_pkgname"
+}
+