summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c97e34c70d12..f687b8f1cede 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = helm-diff
pkgdesc = Helm plugin that shows a diff explaining what a helm upgrade would change
pkgver = 3.1.1
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/databus23/helm-diff
install = helm-diff.install
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 36a5f7745b65..eccaa05ec2b3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: ml <ml@visu.li>
pkgname=helm-diff
pkgver=3.1.1
-pkgrel=2
+pkgrel=3
pkgdesc='Helm plugin that shows a diff explaining what a helm upgrade would change'
arch=('x86_64')
url='https://github.com/databus23/helm-diff'
@@ -26,6 +26,7 @@ prepare() {
build() {
cd "${pkgname}-${pkgver}"
+ export CGO_ENABLED=1
export CGO_LDFLAGS="$LDFLAGS"
export CGO_CFLAGS="$CFLAGS"
export CGO_CPPFLAGS="$CPPFLAGS"
@@ -41,6 +42,7 @@ check() {
package() {
cd "${pkgname}-${pkgver}"
- install -Dm755 bin/diff -t "${pkgdir}/usr/lib/helm/plugins/helm-diff/bin"
- install -m644 plugin.yaml -t "${pkgdir}/usr/lib/helm/plugins/helm-diff"
+ # /usr/lib/helm/plugins is my own choice and not a standard. feedback welcome
+ install -Dm755 bin/diff -t "${pkgdir}/usr/lib/helm/plugins/${pkgname}/bin"
+ install -m644 plugin.yaml -t "${pkgdir}/usr/lib/helm/plugins/${pkgname}"
}