summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
-rw-r--r--helm-diff.install2
3 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f687b8f1cede..5c074f50d7e2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = helm-diff
pkgdesc = Helm plugin that shows a diff explaining what a helm upgrade would change
pkgver = 3.1.1
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/databus23/helm-diff
install = helm-diff.install
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index eccaa05ec2b3..116ca15b88f8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: ml <ml@visu.li>
pkgname=helm-diff
pkgver=3.1.1
-pkgrel=3
+pkgrel=4
pkgdesc='Helm plugin that shows a diff explaining what a helm upgrade would change'
arch=('x86_64')
url='https://github.com/databus23/helm-diff'
@@ -43,6 +43,6 @@ check() {
package() {
cd "${pkgname}-${pkgver}"
# /usr/lib/helm/plugins is my own choice and not a standard. feedback welcome
- install -Dm755 bin/diff -t "${pkgdir}/usr/lib/helm/plugins/${pkgname}/bin"
- install -m644 plugin.yaml -t "${pkgdir}/usr/lib/helm/plugins/${pkgname}"
+ install -Dm755 bin/diff -t "${pkgdir}/usr/lib/helm/plugins/${pkgname##helm-}/bin"
+ install -m644 plugin.yaml -t "${pkgdir}/usr/lib/helm/plugins/${pkgname##helm-}"
}
diff --git a/helm-diff.install b/helm-diff.install
index 6c17ca71d07f..d6909a5c78de 100644
--- a/helm-diff.install
+++ b/helm-diff.install
@@ -1,4 +1,4 @@
post_install() {
echo "Run the following command to finish plugin installation:"
- echo -e "\thelm plugin install /usr/lib/helm/plugins/helm-diff"
+ echo -e "\thelm plugin install /usr/lib/helm/plugins/diff"
}