summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD35
2 files changed, 23 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d80abae22737..773cfa5bb2f2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,10 @@
pkgbase = helm-s3
- pkgdesc = Helm plugin that allows to use AWS S3 as a [private] chart repository
+ pkgdesc = Helm plugin that allows to set up a chart repository in AWS S3
pkgver = 0.10.0
pkgrel = 1
url = https://github.com/hypnoglow/helm-s3
install = helm-s3.install
arch = x86_64
- groups = helm-plugins
license = MIT
makedepends = go
depends = helm
@@ -13,4 +12,3 @@ pkgbase = helm-s3
sha256sums = 0828ba5f4024a9cb98a5a41f42805fa93c7ed0734881d40e7e41ec74727764e0
pkgname = helm-s3
-
diff --git a/PKGBUILD b/PKGBUILD
index 5052e5d289e0..43ddd3fe76ad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,43 +1,52 @@
-# Maintainer: ml <ml@visu.li>
+# Maintainer: Mario Finelli <mario at finel dot li>
+# Contributor: ml <ml@visu.li>
+
pkgname=helm-s3
pkgver=0.10.0
pkgrel=1
-pkgdesc='Helm plugin that allows to use AWS S3 as a [private] chart repository'
-arch=('x86_64')
-url='https://github.com/hypnoglow/helm-s3'
-license=('MIT')
+pkgdesc="Helm plugin that allows to set up a chart repository in AWS S3"
+arch=(x86_64)
+url=https://github.com/hypnoglow/helm-s3
+license=(MIT)
install=helm-s3.install
-groups=('helm-plugins')
-depends=('helm')
-makedepends=('go')
+depends=(helm)
+makedepends=(go)
source=("${url}/archive/v${pkgver}/${pkgname}-${pkgver}.tar.gz")
sha256sums=('0828ba5f4024a9cb98a5a41f42805fa93c7ed0734881d40e7e41ec74727764e0')
prepare() {
cd "${pkgname}-${pkgver}"
+ export GOPATH="${srcdir}/gopath"
+ go mod download
sed -i '/^hooks:$/Q' plugin.yaml
}
build() {
cd "${pkgname}-${pkgver}"
+ export GOPATH="${srcdir}/gopath"
export CGO_ENABLED=1
export CGO_LDFLAGS="$LDFLAGS"
export CGO_CFLAGS="$CFLAGS"
export CGO_CPPFLAGS="$CPPFLAGS"
export CGO_CXXFLAGS="$CXXFLAGS"
export GOFLAGS='-buildmode=pie -trimpath -modcacherw -mod=readonly'
- go build -o bin/helms3 -ldflags "-linkmode=external -X main.version=${pkgver}" ./cmd/helms3
+ go build -o bin/helms3 \
+ -ldflags "-linkmode=external -X main.version=${pkgver}" ./cmd/helms3
}
check() {
cd "${pkgname}-${pkgver}"
make test-unit
- # grep -Fqm1 "$pkgver" bin/helms3
}
package() {
cd "${pkgname}-${pkgver}"
- install -Dm755 bin/helms3 -t "${pkgdir}/usr/lib/helm/plugins/${pkgname##helm-}/bin"
- install -m644 plugin.yaml -t "${pkgdir}/usr/lib/helm/plugins/${pkgname##helm-}"
- install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+
+ # /usr/lib/helm/plugins follows other helm plugins on the AUR (e.g., helm-diff)
+ install -Dm0755 bin/helms3 -t "${pkgdir}/usr/lib/helm/plugins/${pkgname##helm-}/bin"
+ install -m0644 plugin.yaml -t "${pkgdir}/usr/lib/helm/plugins/${pkgname##helm-}"
+
+ install -Dm0644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
+
+# vim: set ts=2 sw=2 et: