summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD47
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..39474b409b53
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Wed Aug 30 14:40:22 UTC 2017
+pkgbase = hengband-git
+ pkgdesc = A variant of angband
+ pkgver = v2.1.4.r375.ga393fd11
+ pkgrel = 1
+ url = http://hengband.osdn.jp
+ arch = i686
+ arch = x86_64
+ license = unknown
+ depends = ncurses
+ source = git://git.osdn.net/gitroot/hengband/hengband.git
+ md5sums = SKIP
+
+pkgname = hengband-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..117f9a95b256
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: yantene <contact at yantene dot net>
+
+pkgname=hengband-git
+_gitname=hengband
+pkgver=v2.1.4.r376.g02901956
+pkgrel=1
+pkgdesc="A variant of angband"
+arch=('i686' 'x86_64')
+url="http://hengband.osdn.jp"
+license=('unknown')
+depends=('ncurses')
+source=(git://git.osdn.net/gitroot/hengband/hengband.git)
+md5sums=('SKIP')
+
+pkgver() {
+ cd $_gitname
+ git describe --tags --always | sed -e 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd $_gitname
+ ./bootstrap
+}
+
+build() {
+ cd $_gitname
+
+ ./configure --with-libpath=/usr/lib/hengband/
+ make
+}
+
+package() {
+ cd $_gitname
+
+ install -d "${pkgdir}/usr/lib"
+
+ install -D -m755 "src/hengband" "${pkgdir}/usr/bin/hengband"
+ cp -R ./lib/ "${pkgdir}/usr/lib/hengband"
+ chmod -R 775 "${pkgdir}/usr/lib/hengband"
+ chown -R root:users "${pkgdir}/usr/lib/hengband"
+
+# removing unneeded files
+ find "${pkgdir}" -iname delete.me -delete
+ find "${pkgdir}" -iname Makefile -delete
+ find "${pkgdir}" -iname Makefile.am -delete
+ find "${pkgdir}" -iname Makefile.in -delete
+}