summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD23
3 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a0fd60158e32
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = herbe
+ pkgdesc = Daemon-less notifications without D-Bus. Minimal and lightweight.
+ pkgver = 1.0.0
+ pkgrel = 1
+ epoch = 1
+ url = https://github.com/trizen/herbe
+ arch = i686
+ arch = x86_64
+ license = MIT
+ depends = libx11
+ source = herbe-1.0.0.tar.gz::https://github.com/dudik/herbe/archive/1.0.0.tar.gz
+ sha256sums = 78e454159050c86e030fb5a6cf997ac914345210cdf5a4ca4d7600c5296b7f76
+
+pkgname = herbe
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..92b4ac4334dd
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+*.zst
+/src
+/pkg
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..76289acf39d6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Franc[e]sco <lolisamurai@tfwno.gf>
+
+pkgname=herbe
+pkgver=1.0.0
+pkgrel=1
+epoch=1
+pkgdesc="Daemon-less notifications without D-Bus. Minimal and lightweight."
+arch=('i686' 'x86_64')
+url="https://github.com/trizen/${pkgname}"
+license=('MIT')
+depends=(libx11)
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/dudik/${pkgname}/archive/${pkgver}.tar.gz")
+sha256sums=('78e454159050c86e030fb5a6cf997ac914345210cdf5a4ca4d7600c5296b7f76')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+}