summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD42
3 files changed, 39 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5bab428fd011..3f22a26fa0df 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,16 @@
pkgbase = herbe-git
- pkgver = 1
- pkgrel = 1
- url = https://github.com/dudik/herbe
- arch = any
- license = MIT
- makedepends = git
- source = git+https://github.com/dudik/herbe.git
- md5sums = SKIP
+ pkgdesc = Daemon-less notifications without D-Bus
+ pkgver = 1.0.0.r10.gdec89e4
+ pkgrel = 3
+ url = https://github.com/dudik/herbe
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ depends = libx11
+ depends = libxft
+ provides = herbe
+ conflicts = herbe
+ source = herbe-git::git+https://github.com/dudik/herbe
+ md5sums = SKIP
pkgname = herbe-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..3db540852b5e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.gz
+*.zst
+/src
+/pkg
diff --git a/PKGBUILD b/PKGBUILD
index 8c06d142f8c8..c7f5bbaa268e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,31 @@
-# Maintainer: Samuel Dudík <dudik at tutanota dot com>
-_pkgname=herbe
-pkgname=$_pkgname-git
-pkgver=1
-pkgrel=1
-arch=(any)
+# Maintainer: Lancia Greggori <lanciagreggori@gmail.com>
+
+pkgname=herbe-git
+pkgver=1.0.0.r10.gdec89e4
+pkgrel=3
+pkgdesc='Daemon-less notifications without D-Bus'
+arch=('x86_64')
+url='https://github.com/dudik/herbe'
license=('MIT')
+depends=('libx11' 'libxft')
makedepends=('git')
-url="https://github.com/dudik/$_pkgname"
-source=("git+https://github.com/dudik/$_pkgname.git")
+provides=("${pkgname%-*}")
+conflicts=("${pkgname%-*}")
+source=("${pkgname}::git+${url}")
md5sums=('SKIP')
-prepare() {
- cd $_pkgname
- if [ -f "$srcdir/config.h" ]; then
- cp -f "$srcdir/config.h" config.h
- fi
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
-build () {
- cd "$_pkgname"
- make
+build() {
+ cd "$pkgname"
+ make clean all
}
-package () {
- cd "$_pkgname"
- mkdir -p "$pkgdir/usr/local/bin"
- cp $_pkgname "$pkgdir/usr/local/bin/"
+package() {
+ cd "$pkgname"
+ make PREFIX=/usr DESTDIR="$pkgdir/" install
+ install -D -m 644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}