summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD44
2 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..483917f44a3d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = heroku-audit
+ pkgdesc = Command-line tool for reporting on specific attributes of a Heroku environment.
+ pkgver = 0.0.2
+ pkgrel = 1
+ url = https://github.com/torchbox/heroku-audit
+ arch = x86_64
+ license = BSD
+ makedepends = python-build
+ makedepends = python-wheel
+ depends = zlib
+ depends = readline
+ depends = xz
+ depends = openssl
+ depends = glibc
+ depends = expat
+ depends = bzip2
+ depends = libffi
+ depends = util-linux-libs
+ depends = ncurses
+ depends = mpdecimal
+ source = https://github.com/torchbox/heroku-audit/archive/0.0.2.tar.gz
+ sha256sums = 0c539746c4b5dfb1ff8504e1a96394c3456666c866e0f0c1f7f54ef6f1242279
+
+pkgname = heroku-audit
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7b0610f297b3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Jake Howard <aur at theorangeone dot net>
+pkgname=heroku-audit
+pkgver=0.0.2
+pkgrel=1
+pkgdesc="Command-line tool for reporting on specific attributes of a Heroku environment."
+url="https://github.com/torchbox/heroku-audit"
+license=('BSD')
+arch=('x86_64')
+depends=(zlib readline xz openssl glibc expat bzip2 libffi util-linux-libs ncurses mpdecimal)
+source=("https://github.com/torchbox/heroku-audit/archive/${pkgver}.tar.gz")
+makedepends=(python-build python-wheel)
+sha256sums=('0c539746c4b5dfb1ff8504e1a96394c3456666c866e0f0c1f7f54ef6f1242279')
+
+build() {
+ cd "${srcdir}"/${pkgname}-${pkgver}
+
+ # Create a temporary virtualenv to install the build dependencies in
+ python -m venv venv
+ source venv/bin/activate
+
+ pip install -e . pyinstaller
+
+ venv/bin/pyinstaller -D --strip heroku_audit/__main__.py --name heroku-audit --clean --noconfirm
+}
+
+check() {
+ cd "${srcdir}"/${pkgname}-${pkgver}
+
+ ./dist/heroku-audit/heroku-audit --version > /dev/null
+ ./dist/heroku-audit/heroku-audit --list > /dev/null
+}
+
+package() {
+ cd "${srcdir}"/${pkgname}-${pkgver}
+
+ mkdir -p "${pkgdir}"/opt
+ cp -r dist/heroku-audit "${pkgdir}"/opt/heroku-audit
+
+ mkdir -p "${pkgdir}"/usr/bin/
+ ln -s /opt/heroku-audit/heroku-audit "${pkgdir}"/usr/bin/
+
+ install -Dm644 README.md "${pkgdir}"/usr/share/doc/${pkgname}/README.md
+ install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
+}