summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD24
2 files changed, 16 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1c462442c2dc..45cbcd369402 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = heroku-cli
pkgdesc = a tool for creating and managing Heroku apps from the command line
- pkgver = 6.14.16
- pkgrel = 1
+ pkgver = 6.14.20
+ pkgrel = 2
url = https://devcenter.heroku.com/articles/heroku-cli
arch = i686
arch = x86_64
@@ -13,10 +13,10 @@ pkgbase = heroku-cli
conflicts = heroku-client-standalone
conflicts = heroku-toolbelt
conflicts = ruby-heroku
- source_i686 = https://cli-assets.heroku.com/heroku-cli/channels/stable/heroku-cli-linux-x86.tar.gz
- md5sums_i686 = 12d109374a5c7fc9e1d85c86445d09be
- source_x86_64 = https://cli-assets.heroku.com/heroku-cli/channels/stable/heroku-cli-linux-x64.tar.gz
- md5sums_x86_64 = 9e7b3bbf44bb9c2263ccc6ce2c99bfb6
+ source_i686 = https://cli-assets.heroku.com/heroku-cli/channels/stable/heroku-cli-v6.14.20-737bba7-linux-x64.tar.gz
+ md5sums_i686 = 9ccef74dcbf7e98afbf964b75da8a66f
+ source_x86_64 = https://cli-assets.heroku.com/heroku-cli/channels/stable/heroku-cli-v6.14.20-737bba7-linux-x64.tar.gz
+ md5sums_x86_64 = 5f19a330f2a3a1f71bc1db3d8f5cf4b3
pkgname = heroku-cli
diff --git a/PKGBUILD b/PKGBUILD
index c1339dd615ba..25e89ebbf9e7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,9 @@
# Maintainer: Rhys Kenwell <redrield+aur@gmail.com>
pkgname=heroku-cli
-pkgver=6.14.16
-pkgrel=1
+pkgver=6.14.20
+pkgrel=2
+_arch=$(uname -m | sed -e "s/86_//; s/i686/x86/")
+_dirname="${pkgname}-v${pkgver}-737bba7-linux-${_arch}"
pkgdesc="a tool for creating and managing Heroku apps from the command line"
arch=('i686' 'x86_64')
url="https://devcenter.heroku.com/articles/heroku-cli"
@@ -9,24 +11,18 @@ license=('custom' 'ISC')
optdepends=('git: Deploying to Heroku')
provides=('heroku-cli')
conflicts=('heroku-cli' 'heroku-client-standalone' 'heroku-toolbelt' 'ruby-heroku')
-source_x86_64=('https://cli-assets.heroku.com/heroku-cli/channels/stable/heroku-cli-linux-x64.tar.gz')
-source_i686=('https://cli-assets.heroku.com/heroku-cli/channels/stable/heroku-cli-linux-x86.tar.gz')
-md5sums_i686=('12d109374a5c7fc9e1d85c86445d09be')
-md5sums_x86_64=('9e7b3bbf44bb9c2263ccc6ce2c99bfb6')
-
-prepare() {
- cd "${srcdir}"
- dir=$(find . -type d -regextype sed -regex ".*/heroku-cli-.*" | head -n1)
- mv $dir heroku-cli
-}
+source_i686=("https://cli-assets.heroku.com/heroku-cli/channels/stable/${_dirname}.tar.gz")
+source_x86_64=("https://cli-assets.heroku.com/heroku-cli/channels/stable/${_dirname}.tar.gz")
package() {
cd "${srcdir}"
install -dm 755 "${pkgdir}"/opt
install -dm 755 "${pkgdir}"/usr/bin
- install -Dm 644 heroku-cli/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm 644 "${_dirname}"/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- mv heroku-cli "${pkgdir}"/opt/heroku-cli
+ mv "${_dirname}" "${pkgdir}"/opt/heroku-cli
ln -s /opt/heroku-cli/bin/heroku "${pkgdir}"/usr/bin/heroku
}
+md5sums_i686=('9ccef74dcbf7e98afbf964b75da8a66f')
+md5sums_x86_64=('5f19a330f2a3a1f71bc1db3d8f5cf4b3')