summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD10
2 files changed, 4 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 16b1905c87fc..c1abe195a9ea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = heroku-cli
pkgdesc = CLI to manage Heroku apps and services with forced auto-update removed
pkgver = 7.47.11
- pkgrel = 1
+ pkgrel = 2
url = https://devcenter.heroku.com/articles/heroku-cli
arch = any
license = custom
license = ISC
makedepends = npm
+ makedepends = yarn
makedepends = perl
depends = nodejs
optdepends = git: Deploying to Heroku
diff --git a/PKGBUILD b/PKGBUILD
index def628d964a0..90b93f378ce4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,14 +4,14 @@
pkgname=heroku-cli
pkgver=7.47.11
-pkgrel=1
+pkgrel=2
_builddir=cli-$pkgver-$pkgrel
pkgdesc="CLI to manage Heroku apps and services with forced auto-update removed"
arch=('any')
url="https://devcenter.heroku.com/articles/heroku-cli"
license=('custom' 'ISC')
depends=('nodejs')
-makedepends=('npm' 'perl')
+makedepends=('npm' 'yarn' 'perl')
optdepends=('git: Deploying to Heroku')
conflicts=('heroku-cli-bin' 'heroku-client-standalone' 'heroku-toolbelt' 'ruby-heroku')
source=("https://github.com/heroku/cli/archive/v$pkgver.tar.gz")
@@ -44,12 +44,6 @@ prepare() {
pushd "cli-$pkgver"
# install packaging tools; install fails now unless installed with yarn >:(
- hasYarn="$(which yarn 2> /dev/null)"
-
- if [ -z "$hasYarn" ]; then
- npm install -g yarn
- fi
-
yarn install
pushd packages/cli