summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD17
-rw-r--r--hexgui.desktop9
-rw-r--r--hexgui.install12
-rw-r--r--hexgui.xml58
5 files changed, 97 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a379bda38855..888b4d031b04 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,9 @@
pkgbase = hexgui
pkgdesc = SGF editor and engine client for the board game Hex
pkgver = 0.9.1
- pkgrel = 1
+ pkgrel = 2
url = http://sourceforge.net/p/benzene/hexgui
+ install = hexgui.install
arch = any
license = GPL3
makedepends = apache-ant
@@ -11,8 +12,12 @@ pkgbase = hexgui
depends = java-runtime
source = https://github.com/apetresc/hexgui/archive/v0.9.1.tar.gz
source = hexgui
+ source = hexgui.xml
+ source = hexgui.desktop
md5sums = eb264a51b3b446d79ef1628a4bbf6e2a
md5sums = 77035cf26c8a2e4c656ad874b44ccf29
+ md5sums = df0600845bfe27c7f5775f274ee12202
+ md5sums = d6c7e88fb22bff99ef68efc26ccb8d56
pkgname = hexgui
diff --git a/PKGBUILD b/PKGBUILD
index 99c1d258eb4d..d800d8465d9d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,19 +3,25 @@
pkgname=hexgui
pkgver=0.9.1
-pkgrel=1
+pkgrel=2
pkgdesc='SGF editor and engine client for the board game Hex'
arch=('any')
url='http://sourceforge.net/p/benzene/hexgui'
license=('GPL3')
depends=('bash' 'java-runtime')
makedepends=('apache-ant' 'java-environment')
-source=("https://github.com/apetresc/hexgui/archive/v$pkgver.tar.gz" 'hexgui')
+install=${pkgname}.install
+source=("https://github.com/apetresc/hexgui/archive/v$pkgver.tar.gz"
+ 'hexgui'
+ 'hexgui.xml'
+ 'hexgui.desktop')
md5sums=('eb264a51b3b446d79ef1628a4bbf6e2a'
- '77035cf26c8a2e4c656ad874b44ccf29')
+ '77035cf26c8a2e4c656ad874b44ccf29'
+ 'df0600845bfe27c7f5775f274ee12202'
+ 'd6c7e88fb22bff99ef68efc26ccb8d56')
build() {
- cd $pkgname-$pkgver
+ cd $pkgname-$pkgver
ant
}
@@ -31,5 +37,6 @@ package() {
cp $srcdir/$pkgname-$pkgver/lib/hexgui.jar $pkgdir/usr/share/java/hexgui/hexgui.jar
cp hexgui $pkgdir/usr/bin/hexgui
+ install -Dm644 ${srcdir}/${pkgname}.desktop ${pkgdir}/usr/share/applications/${pkgname}.desktop
+ install -Dm644 ${srcdir}/${pkgname}.xml ${pkgdir}/usr/share/mime/packages/${pkgname}.xml
}
-
diff --git a/hexgui.desktop b/hexgui.desktop
new file mode 100644
index 000000000000..aa140e5ec0a7
--- /dev/null
+++ b/hexgui.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=HexGui
+GenericName=SGF Editor (Hex)
+Comment=A GUI for Hex
+Exec=/usr/bin/hexgui %U
+Terminal=false
+Type=Application
+Categories=Game;
+MimeType=application/x-hex-sgf;
diff --git a/hexgui.install b/hexgui.install
new file mode 100644
index 000000000000..ece70b0199e4
--- /dev/null
+++ b/hexgui.install
@@ -0,0 +1,12 @@
+post_install() {
+ update-desktop-database -q
+ update-mime-database /usr/share/mime > /dev/null 2>&1
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
diff --git a/hexgui.xml b/hexgui.xml
new file mode 100644
index 000000000000..361dbfc6acdb
--- /dev/null
+++ b/hexgui.xml
@@ -0,0 +1,58 @@
+<?xml version="1.0"?>
+<mime-info xmlns='http://www.freedesktop.org/standards/shared-mime-info'>
+ <mime-type type="application/x-hex-sgf">
+
+ <comment>SGF record</comment>
+ <comment xml:lang="ar">تسجيلة SGF</comment>
+ <comment xml:lang="be@latin">Zapisanaja hulnia SGF</comment>
+ <comment xml:lang="bg">Запис — SGF</comment>
+ <comment xml:lang="ca">registre SGF</comment>
+ <comment xml:lang="cs">nahrávka SGF</comment>
+ <comment xml:lang="da">SGF-optagelse</comment>
+ <comment xml:lang="de">SGF-Aufzeichnung</comment>
+ <comment xml:lang="el">Εγγραφή SGF</comment>
+ <comment xml:lang="en_GB">SGF record</comment>
+ <comment xml:lang="es">grabación SGF</comment>
+ <comment xml:lang="eu">SGF erregistroa</comment>
+ <comment xml:lang="fi">SGF-nauhoitus</comment>
+ <comment xml:lang="fo">SGF met</comment>
+ <comment xml:lang="fr">partie SGF</comment>
+ <comment xml:lang="ga">taifead SGF</comment>
+ <comment xml:lang="gl">Grabación SGF</comment>
+ <comment xml:lang="he">הקלטת SGF</comment>
+ <comment xml:lang="hr">SGF zapis</comment>
+ <comment xml:lang="hu">SGF pontszám</comment>
+ <comment xml:lang="ia">Partita SGF</comment>
+ <comment xml:lang="id">Catatan SGF</comment>
+ <comment xml:lang="it">Registrazione SGF</comment>
+ <comment xml:lang="ja">SGF レコード</comment>
+ <comment xml:lang="kk">SGF жазбасы</comment>
+ <comment xml:lang="ko">SGF 기록 파일</comment>
+ <comment xml:lang="lt">SGF įrašas</comment>
+ <comment xml:lang="lv">SGF ieraksts</comment>
+ <comment xml:lang="nb">SGF-oppføring</comment>
+ <comment xml:lang="nl">SGF-record</comment>
+ <comment xml:lang="nn">SGF-logg</comment>
+ <comment xml:lang="oc">partida SGF</comment>
+ <comment xml:lang="pl">Zapis gry SGF</comment>
+ <comment xml:lang="pt">gravação SGF</comment>
+ <comment xml:lang="pt_BR">Gravação SGF</comment>
+ <comment xml:lang="ro">Înregistrare SGF</comment>
+ <comment xml:lang="ru">запись SGF</comment>
+ <comment xml:lang="sk">Záznam SGF</comment>
+ <comment xml:lang="sl">Datoteka shranjene igre SGF</comment>
+ <comment xml:lang="sq">Regjistrim SGF</comment>
+ <comment xml:lang="sr">СГФ запис</comment>
+ <comment xml:lang="sv">SGF-protokoll</comment>
+ <comment xml:lang="tr">SGF kaydı</comment>
+ <comment xml:lang="uk">запис SGF</comment>
+ <comment xml:lang="vi">Mục ghi SGF</comment>
+ <comment xml:lang="zh_CN">SGF 记录</comment>
+ <comment xml:lang="zh_TW">SGF 紀錄</comment>
+ <acronym>SGF</acronym>
+ <expanded-acronym>Smart Game Format</expanded-acronym>
+ <generic-icon name="text-x-generic"/>
+ <glob pattern="*.hsgf"/>
+ <sub-class-of type="text/plain"/>
+ </mime-type>
+</mime-info>