summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1c7ab219196a..3599d2cb3ed9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,10 +17,10 @@ build() {
}
check() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
# Tests depend of Mercurial sources
if [[ -n "$HGSRC" ]]; then
- cd "${srcdir}/${pkgname}-${pkgver}/tests"
- python2 "${HGSRC}/tests/run-tests.py"
+ make tests HGROOT="${HGSRC}" PYTHON=python2
fi
}